Discord download

I just recently downloaded Discords tar.gz file and extracted it to my downloads folder. But what comes next?

Hello sir,

I suggest you use the discord package listed in the AUR (Arch User Repository).

If you’re unfamiliar with the manual build process then you can use a package helper like aurman, yay, yaourt, etc.

Otherwise the manual process is actually quite easy and informative, see here regarding the steps
https://wiki.archlinux.org/index.php/Arch_User_Repository#Installing_packages

You may also build from source which is likely what you will get if using the official discord download for linux, depending on what is inside the process may be slightly different. Generally speaking most software grabbed from source can be installed by finding the folder containing a Makefile then running

sudo make clean install

However like I said this can differ, if you want to continue this way please post the contents of the extracted archive.

Any other questions feel free to ask.

Cheers

2 Likes

I’m not familiar with any of this…

Then I suggest you start reading up or go back to running a different os :slight_smile:

natemaia’s summary is spot on and the arch wiki is an awesome source of information on anything related to arch.

I know your intention isn’t too offend, but please, none of this Arch Forum stuff here.

7 Likes

@grunge94 , to fully enjoy ArchLabs (as any Arch based OS) you should really learn a bit more how it works, I can see you tried the Debian(ish) approach to install a package not in the repositories, but here (Arch) it doesn’t work the same way.
I have read that you are intresetd in IT, even looking fo a job in it, so it shouldn’t be a problem to get familiar with a new concept.
In Arch there’s plenty of documentaton and for anything else we are here to help each other.
But you need to be open-minded…

I appreciate this info! I’ll be diving more into learning the cmd line more and reading about Pacman.

I understand the confusion. My experience has been with debian as well. Pacman and aurman, and their connection are somewhat confusing to me. The fact that aurman is called a ‘helper’ has, well, helped me a bit. I definitely need to read more and understand what the heck I’m doing.

You’re not alone. :slightly_smiling_face:

1 Like

Yay I’m not the only one who is struggling lol! I’m currently going through a book called The Linux Command Line by William E. Shotts, Jr. So far it’s pretty good. I’m currently in the redirection chapter.

1 Like

That’s a pretty good book and I’m glad you are reading it. I wish more beginners would do so. I say BRAVO!

2 Likes

Yes indeed! It has some very valuable info in there!

1 Like

If you want to avoid all the mess and you are running a recent version of AL then running the following should see discord installed with minimal effort

aurman -S discord

Do note that aurman is no longer supported as the author has stopped working on it, prior to this it seemed like the best AUR helper to use.

You could also use my AUR helper if you are looking for something simple and minimal
https://bitbucket.org/natemaia/baph

baph -i discord
3 Likes

Hi. I have a new install of ArchLabs latest release and I tried using aurman -S discord to download and install Discord, but I got an error:

Could this have something to do with the fact that aurman is deprecated? How do I fix this?

No this is just a gpg issue, the error: FAILED (unknown public key A2C794A986419D8A) is where the issue is.

Couple options here

  • use baph listed above, it can handle dependency chains like this.

  • install libc++ directly before discord using aurman -S libc++ this way aurman should import the keys from the package.

  • import the keys before doing the install (see below)

gpg --receive-keys "A2C794A986419D8A"
sudo pacman-key -r "A2C794A986419D8A"
sudo pacman-key --lsign-key "A2C794A986419D8A"
3 Likes

Don’t mean to be a dick but the key to the issue is right there in the error.

Hello. The second solution gives me the same error as trying to download and install Discord. The thrid also gives me an error.
My guess is that the libc++ gpgkey is the only problem here. So I looked up the gpgkey on Google and found this link, that offers two solutions:
https://arcolinux.com/how-to-fix-one-or-more-pgp-signatures-could-not-be-verified-libc-and-discord/
I tried the first; adding the key servers to the gpg.conf file, then getting the keys through natemaia’s third option (importing the keys), then installing libc++ (a process that took 20+ minutes, bizarrely). Finally, I installed Discord using aurman -S discord. It worked and I’m now using Discord.
Thank you so much for all of your help and patience.

1 Like

@plebeu Glad you’ve got it sorted out. :slight_smile:

Please mark the post which best offered you help as the solution so others may benefit as well.

@anon37345411 , plebeu isn t the op , taught the same myself here.

1 Like

Ohhhh yeeah… Guess that makes a difference :crazy_face:

I’ll just mark his to hide that fact and save face hehehe! :rofl:

1 Like

You bet ! lol