Disabling Terminal Startup Script


#1

Hello, new ArchLabs user and absolutely loving this on i3! Does anyone know how to disable the neofetch/screenfetch like script that executes when a new terminal is opened? This seems like a nice touch to Openbox, but is a little much when launching and tiling several windows within i3. Thanks in advance!


#2

Remove the entry from your bash/zshrc called “al-info”.

Next time you start the terminal it will be gone :).


#3

That did it, thank you sir!


#4

Anytime :smiley:

If you could mark the post solved please. You do this by selecting the square with the tick next to reply :smiley:


#5

Hi, i remove the line ´´al-info´´ but still appears :wink:


#6

Show me your bashrc or zshrc.


#7
#!/bin/bash

# catch non-bash and non-interactive shells
[[ $- == *i* && $BASH_VERSION ]] && SHELL=/bin/bash || return 0

# set some defaults
export MANWIDTH=100
export HISTSIZE=10000

export HISTIGNORE="q:f:v"

# colors in less (manpager)
export LESS_TERMCAP_mb=$'\e[01;31m'
export LESS_TERMCAP_md=$'\e[01;31m'
export LESS_TERMCAP_me=$'\e[0m'
export LESS_TERMCAP_se=$'\e[0m'
export LESS_TERMCAP_so=$'\e[01;44;33m'
export LESS_TERMCAP_ue=$'\e[0m'
export LESS_TERMCAP_us=$'\e[01;32m'

# ensure ~/bin is on the path
[[ $PATH =~ ~/bin ]] || PATH=~/bin:$PATH

set -o vi
set -o notify

shopt -s direxpand
shopt -s checkhash
shopt -s sourcepath
shopt -s expand_aliases
shopt -s autocd cdspell
shopt -s extglob dotglob
shopt -s no_empty_cmd_completion
shopt -s autocd cdable_vars cdspell
shopt -s cmdhist histappend histreedit histverify
[[ $DISPLAY ]] && shopt -s checkwinsize

# prompt if file sourcing below fails
PS1='[\u@\h \W]\$ '

# uncomment these lines to disable the multi-line prompt
# add user@host, and remove the unicode line-wrap characters

# export PROMPT_LNBR1=''
# export PROMPT_MULTILINE=''
# export PROMPT_USERFMT='\u\[\e[0m\]@\[\e[31m\]\h '

# source shell configs
for f in "$HOME/.bash/"*?.bash; do
    . "$f"
done

al-info

#8

Alrighty, at the very bottom there remove al-info and you should be good to go.

P.S. please use code tags when posting stuff like that.


#9

ok sorry and thank you


#10

No need to apologise :smiley: Just was a reminder.


#11

after logout the script keeps coming… i can live with that :wink:


#12

If you reboot, what it does.


#13

Are you using bash or zsh? If you are using zsh you will need to removed al-info from the zshrc as well.


#14

im using Bash


#15

i will try it


#16

Sometimes it takes effects only after reboots, might not do anything, but never know.


#17

once you remove al-info from .bashrc it shouldn’t show again.


#18

after rebooting the system the script persists


#19

Well , it must be on zhs I guess.( was it removed , zhs I mean)


#20

You can’t have deleted al-info from .bashrc.

I did it just now on my test laptop and it worked.