Disable autologin

I’ve researched other threads in the forum, but I couldn’t find any solution that fits my needs.

I don’t want to install lightdm.

I want to boot the system and be presented with a terminal that asks for my user and password. Then after I log in, it will startx automatically.

So, basically what it does by default, but asking for my user and password (or just password).

I tried:

sudo gpasswd -d $USER autologin

However, it took no effect.

Hi @tgomes95, if I am understanding correctly your query, you will need to install a login manager like lightdm or similar and the enable it in your autostart file.

Sorry. I’ve updated the question. What I meant by “black screen” is the terminal that gets skipped when we boot the system.

You will need to edit the systemd services:

disable auto login ArchLabs

Skip the first part of the thread which disables the auto startx after logging in. Nate has a post near the end about disabling the systemd service that logs the user in.

4 Likes

Oh, great! Thanks! I had missed that!

So, basically my solution:

sudo gpasswd -d $USER autologin
sudo rm -r /etc/systemd/system/getty@tty1.service.d

4 Likes

@tgomes95, sorry, I didn’t get the question right. I am glad you got the solution anyway. See you around!

3 Likes