Dimension Error after startup

Have you tried stopping the LightDM service and just logging in from the console with startx?

1 Like

I cannot stop lightdm as i run command systemctl stop lightdm
But as i restart the pc lightdm is working.

The right resolution for your model seems to be 1920x1080 according to HP, so try this:

  1. Identify primary output and resolution:
xrandr -q
  1. build the command for the script from this output
    part of the output is like:
eDP1  connected primary  1920x1080 +0+0

script command is like:

xrandr --output  eDP1  --mode  1920x1080  --dpi 96
  1. set display-setup-script path:
sudo nano /etc/lightdm/lightdm.conf

go to section [Seat:*]
uncomment (change) #display-setup-script= to display-setup-script=/etc/lightdm/Xsetup

  1. insert the command for setting the resolution in the script:
sudo nano /etc/lightdm/Xsetup

insert command from step 2 and save:

xrandr --output  eDP1  --mode  1920x1080  --dpi 96
  1. make it executable:
sudo chmod +x /etc/lightdm/Xsetup
  1. reboot

Ps: Don’t be frustrated if you don’t get the screen as perfect as you get it on Windows.

1 Like

Yes @Beast
I had used it eralier but at the time such problem doesnot persist but as i reinstall it with current iso such problem persist
Ok i will try the solution.

Simpler version:

xrandr --size 1920x1080

X uses 96 DPI by default.

An alternative method would be an X.Org configuration file, something like this should do the trick:

# /etc/X11/xorg.conf.d/10-monitor.conf
Section "Monitor"
   Identifier "eDP1"
   Option "PreferredMode" "1920x1080"
EndSection

But I think the OP might be able to fix this by enabling early KMS for the Intel card:

https://wiki.archlinux.org/index.php/Kernel_mode_setting#Early_KMS_start

To disable LightDM use

systemctl disable --now lightdm
1 Like

Thank you very much @Beast.
The first solution worked.

1 Like

Glad that it s resolved on your end @Bibek .

Please mark it as solved & click on @Beast Solution as it fixed your issue .

Have a great one.

We are all very glad to hear that @Bibek. Enjoy your system!

1 Like

Now it looks clean and complete @anon42040838, brother i dind’t know about the X.org file. Thanks man!

1 Like