Default Term in openbox doesn't run anymore

Hi
SInce update, my default Terminal Emulator (which is Alacritty) doesn’t launch when I use keybinds.

capture_2021-12-04-37_498x132

Here is a part of my rc.xml

<keybind key="W-Return">
      <action name="Execute">
        <command>exo-open --launch TerminalEmulator</command>
      </action>

When I type

exo-open TerminalEmulator

I get

/usr/bin/termite: error while loading shared libraries: libicuuc.so.69: cannot open shared object file: No such file or directory

so I understand alacritty isn’t my default anymore. Why ?

You need to update your system:

pacman -Syu

If you’re seeing soname errors then you’ve been running partial upgrades. Don’t do that, it breaks Arch-based systems.

EDIT: to change the exo-open preferences use

exo-preferred-applications

The only exo- commands I have are:

exo-desktop-item-edit  exo-open

Ah yes, it appears that is gone:

https://bbs.archlinux.org/viewtopic.php?id=262285

So:

pacman -Syu xfce4-settings # probably already installed
xfce4-mime-settings

Apologies for the misinformation, I don’t use Xfce.

1 Like