Default Screenshot Directory

Hey Fellas,

So the default screenshots taken from the menu save to the ‘Pictures’ folder. I am trying to find a way to change where it saves. So far I haven’t been able to find the right file to edit. I was hoping someone could share their wisdom on this subject, thanks

@Dobbie03 I did find your post on the screenshot script which works great, but I would like to make use of the timers in the menu.

1 Like

On the openbox menu -

Preferences -> Openbox -> Menu Editor

That will bring up the Kickshaw menu editor; you can expand the menu entries to see what the various commands are. In this case, expand the screenshot menu to see the command used for various screenshot options. It’s a command, not a script, so you can edit the menu option directly and then save the new menu.

2 Likes

Thanks! Working/Learning as we speak…or type…whatever…

@TimApple, you all sorted mate?
I recently updated my PrintScrn command to this:

scrot -m -d 5 ‘%Y-%m-%d–%s_$wx$h_scrot.png’ -e ‘mv $f ~/Screenshots/ ; gpicview ~/Screenshots/$f’

This gives me time to fire up Rofi or Obmenu if I want to show anything, automatically moves the scrot to my screenshot folder then opens gpicview if I want to edit or whatever the image.

1 Like

Sure am…thanks!

1 Like

where do i put this - trying to change the location as well

Put what where?

You mean screenshot directory or the scrot command or scrot script?

your PrintScrn post i want to change the screenshot location

You change it in the code above in your config file. Are you openbox or i3 or something else?

Openbox

Change the command in your rc.xml.

I replaced the commands here

  <action name="Execute">
    <command>scrot 'ArchLabs_%Y-%m-%d-%S_$wx$h.png' -e 'mv $f $$(xdg-user-dir PICTURES) ; gpicview $$(xdg-user-dir PICTURES)/$f'</command>
  </action>
</keybind>
<keybind key="A-Print">
  <action name="Execute">
    <command>scrot -d 5 'ArchLabs_%Y-%m-%d-%S_$wx$h.png' -e 'mv $f $$(xdg-user-dir PICTURES) ; gpicview $$(xdg-user-dir PICTURES)/$f'</command>

but it still ends up in the Pictures folder

Because you haven’t actually change the directory where the screenshot is being saved.

Replace the text between command…/command

Keep the <

with:

scrot -m -d 5 ‘%Y-%m-%d–%s_$wx$h_scrot.png’ -e ‘mv $f ~/Screenshots/ ; gpicview ~/Screenshots/$f’

I must be doing something wrong - it still goes to the Pictures folder - it’s saved and refreshed Openbox

Are you taking the screenshot with the key binding (Print or Alt-Print) - those look correct, or are you taking the screenshot from the menu?

If you’re using the menu options for taking a screenshot, that will be reading a command in the menu.xml file and saving your shot to the default “Pictures” location. . You will need to edit that file and change “Pictures” to “Screenshots”.

You can use the: Preferences -> Openbox -> Menu GUI to edit, or your favorite test editor.

1 Like

Not sure but you might have to log out and in in order of having the changes effectives right ?

Or just “Reconfigure”.

thank you @Dobbie03 @PackRat (i am using the menu) it moved to the home folder - but i will just leave it the stock way - for some reason it’s not working for me - i might use another option

Give me your rc.xml and I will change it.

i got it fixed @anon52460207 assisted last night thanks - we change rc.xml for the default and the menu.xml for the Openbox menu and now all is good

2 Likes