Default applications

Hi Archlabbers!

I have a little problem with default applications. I use openbox and I can not find where to change default applications. Am trying to use xdg-open but it is not possible to change default application that way. Only to check. Are there any experts in openbox out there?

Womp

Try on with Obmenu @womp , should do the trick

Edit: wrong name !

1 Like

@womp obmenu–> Preferences–> Settings Manager–> Preferred Applications

Logout & back in again… Good to go :slight_smile:

3 Likes

You re much better at explaining than me @anon37345411

2 Likes

No man, just a big mouth lol

3 Likes

lol, bad boy also !

2 Likes

exo-preferred-applications also does the same thing. Launch it from Rofi or Dmenu.

1 Like

Thank you guys for answers!
My prefered browser is Firefox for the moment but when I open links from thunderbird, they open in Midori even though I have Firefox set as prefered browser.
Can not find anywhere to change this is Thunderbird.

womp

I have just today manually set some default applications using xdg-mime with i3. Can’t say if it is different for openbox, though.
Check Arch wiki for more info.

1 Like

I don’t believe there is one. I seem to remember having a similar issue some time ago. I’d just trick it into using FF by uninstalling Midori, opening a link again in Thunderbird, making certain FF is set as default from within it’s settings and then reinstalling Midori.

1 Like

Have you set in Firefox for it to be the default as well as exo-preferred-applications?

1 Like

Finally! To set it thru Firefox did it! Thank you guys!!

Womp

1 Like

Glad it s working @womp

Thx @Dobbie03 for the solution

2 Likes