Debtap -u sync error


#1

parda@bomb Downloads $ sudo debtap -u
==> Synchronizing pkgfile database…
:: Updating 5 repos…
download complete: archlabs_repo [ 26,0 B 39,0B/s 4 remaining]
error: failed to create archive reader for archlabs_repo: Multibyte ou caractere largo inválido
multilib is up to date
core is up to date
extra is up to date
community is up to date
:: download complete in 0,71s < 26,0 B 36,0B/s 1 file >
Synchronization failed. Exiting…
u caractere largo inválido
multilib is up to date
core is up to date
extra is up to date
community is up to date
:: download complete in 0,71s < 26,0 B 36,0B/s 1 file >
Synchronization failed. Exiting…


#2

I just comment archlabs repo on pacman.conf to sync it.


#3

This is not what the tool is for, use pacman to update your system. It states on the AUR package page for debtap that it should be used to convert .deb packages for Arch, not for packages that exist in the official repos or can be built from the AUR.

Package Details: debtap 3.2.2-1. … A script to convert .deb packages to Arch Linux packages, focused on accuracy. Do not use it to convert packages that already exist on official repositories or can be built from AUR!

Cheers


#4

I know for what debtap is made for, debtap -u is to update “debtap” database.


#5

I have noticed other utilities that attempt to inspect pacman repos also fail, this is not specifc to debtap (perhaps debtap uses pkgfile)?

% sudo pkgfile --update                                                                            :(
:: Updating 5 repos...
  download complete: archlabs_repo        [    26.0   B  63.0B/s  4 remaining]
error: failed to create archive reader for archlabs_repo: Invalid or incomplete multibyte or wide character

#6

I would also include your repo list as well as your AL version please, might help on your issues.


#7

My AL install is about 2 weeks old, from the latest install media (2018.07):

% head -n1 /var/log/pacman.log  
[2018-08-27 21:08] [PACMAN] Running 'pacman -Rs --noconfirm archlabs-installer'

My pacman.conf is completely stock, I have not modified any repos:

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# The multilib repositories are enabled by default in ArchLabs.
# If you don't run 32 bit applications you may comment them out

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

# [archlabs_unstable]
# Server = https://bitbucket.org/archlabslinux/archlabs_unstable/raw/master/$arch

[archlabs_repo]
Server = https://bitbucket.org/archlabslinux/archlabs_repo/raw/master/$arch
Server = https://sourceforge.net/project/archlabs-repo/files/archlabs_repo/$arch

#8

Thx for the comeback , repos look ok to me, unless they changed them lately, let see what some more knowledgaeble members can do to help you.


#9

Before updating I would try in termonal this command;

pacman -Scc

& this one before attempting debtap commands, might help also. Edit: added command

pacman -Syyu


#10

Just FYI, I don’t use debtap. I did try to use pkgfile though. I think it is the same bug. From some preliminary google searching it looks like an encoding error. Is there any metadata in the AL repo that has special unicode characters or something?


#11

Well , wonder if it has to do with key signatures as well.


#12

As for signature keys, have a look at this link if any issues AFTER clearing the cache:

Edit: @Fingel . When updating with pacman, is everything ok !


#13

@altman this is not an issue with syncing packages, pacman upgrades work fine, This is an issue with tools that attempt to inspect pacman repositories failing on the ArchLabs one.

https://wiki.archlinux.org/index.php/Pkgfile


#14

@Fingel , ah thx for clarifying, got mixed here somehow. lol


#15

This must be due to including icon patches fonts in our repo, not entirely sure but it seems logical.

Definitely due to some type of encoding though.


#16

Yeah I am getting this also:

sevenday4@guys-pc  ~  sudo uname -a                      ✔  379  09:27:15
[sudo] password for sevenday4: 
Linux guys-pc 4.19.1-arch1-1-ARCH #1 SMP PREEMPT Sun Nov 4 16:49:26 UTC 2018 x86_64 GNU/Linux
 sevenday4@guys-pc  ~  sudo debtap -u                     ✔  380  09:27:53
[sudo] password for sevenday4: 
==> Synchronizing pkgfile database...
:: Updating 5 repos...
  community is up to date
  core is up to date
  extra is up to date
  multilib is up to date
  download complete: archlabs_repo        [    26.0   B  11.0B/s  0 remaining]
:: download complete in 2.27s             <    26.0   B  11.0B/s  1 file     >
:: waiting for 1 process to finish repacking repos...
error: failed to create archive reader for archlabs_repo: Invalid or incomplete multibyte or wide character
Synchronization failed. Exiting...

In a couple of days I will do a better investigation. I also did a

sudo pacman -Scc
sudo pacman -Syy

Got same results.


#17

Gonna remove all patched fonts from the repo and see if that is indeed the issue, in the future you may get some font icon issues.


#18

@unixpod have you tried using dpkg? You need to install it then:

sudo dpkg -i <package name >


#19

Never knew you could use “dpkg” in Arch.
Thanks :wink:


#20

Same here, taught I was back on BL !