Dark Themes, GTK, Qt, root etc?

Hi,
gnome-disk-utility and evince dont follow my Adwaita-dark theme set in xfce4-settings-manager
Same thing if I select the ArchLabs-Dark theme

I am guessing that the reason for gnome-disk-utility could be because it runs as root?
In that case in terms of this, could anyone advise on the best method to do this? (or if I am completely wrong)

But what about Evince?

I am still confused by this theming stuff, my current idea is that Apps can use GTK or Qt but Adwaita themes should work for both?
And GTK2 is ‘obsolete’ and GTK3 & 4 are maintained/current?

qpdfview and Xpdf also dont follow the theme (old apps, GTK2? - just guessing)

Can anyone shed some dark on this for me? (absolutely pants pun thrown in for free there)

Cheers

Edit this is on Openbox AL if that makes any difference

Xpdf theme is done in the ~/.Xresources file. From my ~/.Xresources

xpdf*Background:    #CFC6BE
xpdf*Foreground:    #050505
xpdf*FontList:      -xos4-terminus-medium-r-normal-*-14-140-72-72-c-80-iso8859-1
xpdf*initialZoom:   page
xpdf*urlCommand:    firefox %s
xpdf*textEncoding:  utf-8

the man page for xpdf will have all the options.

Personal preference. The symlink method will standardize the theme system wide. But from that same page you have:

Adjust the theme as root

That’s the method I use. root gets a dark theme with a red icon set. Always know when I’m running an application as root.

qpdfview is a Qt application show will not look right. There is a setting you can add to your .xprofile so that qt apps follow gtk+ that helps - might be later in that ArchWiki page you linked.

Don’t know what’s going on with evince. Give atril a look. It’s the mate desktop fork of evince.

2 Likes

Thanks!
I did try the Adjust the theme as root way, which I assumed was to simply sudo xfce4-apearance-settings but it didnt open it


leigh@archlabs ~ % sudo xfce4-appearance-settings 
[sudo] password for leigh: 

(xfce4-appearance-settings:31706): xfce4-appearance-settings-ERROR **: 21:58:16.679: Failed to connect to xfconf daemon: Error spawning command line “dbus-launch --autolaunch=626d62d44b334fa5840734b03f5d3871 --binary-syntax --close-stderr”: Child process exited with code 1.
[1]    31673 trace trap  sudo xfce4-appearance-settings

leigh@archlabs ~ % sudo su                       
[root@archlabs leigh]# xfce4-appearance-settings 

(xfce4-appearance-settings:32141): xfce4-appearance-settings-ERROR **: 21:59:06.366: Failed to connect to xfconf daemon: Error spawning command line “dbus-launch --autolaunch=626d62d44b334fa5840734b03f5d3871 --binary-syntax --close-stderr”: Child process exited with code 1.
Trace/breakpoint trap (core dumped)

Atril is the answer to Evince problem - much nicer!
And that means that xpdf and qpdfviewer have both been removed from my system and two of above problems solved :smiley:

EDIT: I installed lxappearance and that ran as root and now all is how I want it - Thanks!

2 Likes

lxappearance is all I ever use for setting themes.

Good that you have it all working.

1 Like

Could you guys check and tell me how nwg-look behaves there? I’ve only tested it on Wayland, but theoretically it should work anywhere.

1 Like

Yup, just removed lxappearance from DK, installed nwg-looks, working great at first glance. Will test further tonight, but i could easily change icons etc.

2 Likes

Thank you. It would be not bad to know if/where it’s usable.

Yes, i will add some more later this week and let you know anyway.

1 Like

Not sure if I am the right person to help with this but …
I installed nwg-look and it looks wonderful
I opened nwg-look, lxappearance, xfce4-appearance-settings alongside each other and changes to widgets in lx or xfce4 immediately mirrored each other, but nwg didnt change, and changes in nwg werent reflected in lx and xfce4.
widget changes in nwg also didnt change grsync or shotwell for example
But then again neither did this work in lx or xfce4!
Something going on that I am not understanding :smiley:
Tried reboot too
Will try to look into this later this week but probably Peppe is going to be more help to you.
Cheers

1 Like

Gtk2 apps won’t respond, as nwg-look used and sets gsettings values. Thanks for testing anyway.

1 Like

Well actually I have the same sometimes with lx appearance and xfce4 settings not completely mirroring settings, probably dependent on the used application (on which it is applied). I always end up going through all, with OpenBox having the ‘extra’ issue of having to find a corresponding OpenBox theme :wink: nwg-shell opened as well this morning, but since it is on dk (and nwg-shell probably expects sway) there were not many bars to be applied. But I’ll need to tweak furthermore tonight, which is fun anyway. It would be great to see the ‘nwg-toolkit’ on top of dk and technically I assume (assumption being the mother of all snafu’s) it should be possible.

2 Likes

No worries, I just wanted to show willing :slight_smile:

I think I know the answer to this question, but why not have one app that changes everything instead of this piecemeal approach? (not directed at your efforts, but Linux themeing globally) - is this not technically / politically possible?

1 Like

Few of my apps may be useful outside Wayland. For sure you could use Azote.

1 Like

Not really, even between GTK & QT. Both have own themes. I know about one common: Adwaita.

That’s a nice fresh one, instead of feh or nitrogen. Appearance is also great, I will keep it installed. Btw, tested out Wayfire and River over the weekend and can confirm that my Nextcloud app issues are Wayland (and not Sway/nwg) related. So the minute that gets fixed I’ll be back.

On X it uses feh as the setter. :slight_smile:

Dunno about Nextcloud. Hope they evolve a bit faster than Firefox.

1 Like

Back to this again :frowning:

I did a fresh AL install after this was sorted with your help

Now running lxappearance as root doesnt change the theme of gnome-disks and I cant work out why
As you can see below, I have Adwaita dark selected for ‘normal’ and root

Edit: Disk usage analyser (baboab) is the same

Edit2: gnome-disks isnt asking for a password when opend from jgmenu or sudo gnome-disks

Look through the menu, see if gnome-disks and baboab have an option to disable Client Side Decoration (CSD).. Some applications do, some don’t. LXappearance can’t change CSD.

1 Like

@PackRat
Thanks. But neither allow me to disable CSD
I wonder what I did before that enabled lxappearance to change them to dark?
I had been trying different things before I made my original post above, perhaps one of them allowed lxappearance to be effective?
I know its possible at least :slight_smile:

It’s because gnome-disks is a GTK4 app I suspect? I had to use some terminal wizardry to get it to adapt to the dark theme butt I cannot find the link or the command I used. I will share it when I can find it.

EDIT:

I can’t be 1000% sure this is what I did as it was a few weeks ago but:

and this in the terminal:

settings set org.gnome.desktop.interface gtk-theme 'Adwaita-dark'

Wish I could find the link and command I used.

2 Likes