D-Bus "Failed to send D-Bus message"

While its not the first time ive gotten these errors(id usually just reboot and theyd go away in a certain amount of times) This is the first time they just persist and refuse to go away, i thought maybe it was an issue with my system files so i time shifted back to a backup from a couple of days ago where this issue was just one every couple of boots but it still persists.
This comes up when i press the super key(windows key) and alt+f1 and i cant do anything in my wm(i3) that involves the superkey

Try removing this line in your i3 config

exec --no-startup-id xfsettingsd

Then restart and see if you still have the same issue.

It’s definitely tied to the rofi bind and ksuperkey that we use in AL, check ~/.xprofile and there is a couple lines that may be the issue, try commenting them and see.

ksuperkey -e 'Super_L=Alt_L|F1' &
ksuperkey -e 'Super_R=Alt_L|F1' &
1 Like

it worked tysm

you’re welcome

1 Like

Please mark it as solved as it can be of some help to other members in the future.

Glad that you had your issue fixed @maid , Props to @natemaia

Welcome !
:slight_smile: