CUPS service not running?

Hi I checked the CUPS server if it was installed i read the wiki arch follow all the steps there but i guess if that doesn’t work i might not be looking it right. I checked https://localhost:631 but wasn’t found. I am curious and won’t give up it’s the only thing left i need to print through cable an wifi and scan :smile:, thanks.

Sounds like cups didn’t get enabled - what is the output of:

systemctl list-unit-files | grep cups

Hi there PackRat, this is what it comes out:

org.cups.cupsd.path enabled
cups-browsed.service disabled
org.cups.cups-lpd@.service static
org.cups.cupsd.service enabled
org.cups.cups-lpd.socket disabled
org.cups.cupsd.socket enabled

I checked https://localhost:631 but wasn’t found.

You mean the printer? First time I read that I thought the page wasn’t showing.

What model of printer are you using? Have you had it working with Linux before?

HI, I have to printers

  1. HP Deskjet 5820 series
  2. HP Photosmart Plus B210 series

So far they work with all distros i tried, even opensuse through the desktjet setup the scanner over wifi worked great. but here the hplip console doesnt open up also.

Hey, sorry for delayed response

Did you install printer support via the first boot script (al-hello) ?
This should do most of the setup for you and with any luck you should be able to just plug-n-go

If not you can re-run it anytime in a terminal with al-hello and simply skip the steps you dont want

If after that setup and a reboot they still aren’t working we can get into specifics

Cheers,
Nate

Don’t worry :wink:, now i am away till the weekend from the printers, as soon as I am near I will run the scrip hello again, i saw it can be be re-run.