CRITICAL: no Qt platform , Fatal Python error: Aborted

It looks like I feckd it up big time, tried to uninstall and reinstall modules and qt5 to no avail, maybe someone can help with some simple steps what should I do/try next? I haven’t used QuteBrowser in a while and I wanted to get back…

~►export QT_DEBUG_PLUGINS=1 I tried running this, but I get no output at all from it and it doesn’t solve anything.

~►qutebrowser 11:22
11:22:27 WARNING: Could not find the Qt platform plugin “xcb” in ""
11:22:27 CRITICAL: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Fatal Python error: Aborted
Current thread 0x00007f66b1146740 (most recent call first):
File “/usr/lib/python3.10/site-packages/qutebrowser/app.py”, line 558 in init
File “/usr/lib/python3.10/site-packages/qutebrowser/app.py”, line 94 in run
File “/usr/lib/python3.10/site-packages/qutebrowser/qutebrowser.py”, line 245 in main
File “/usr/bin/qutebrowser”, line 33 in
Extension modules: PyQt5.QtCore, PyQt5.QtGui, PyQt5.QtWidgets, markupsafe._speedups, yaml._yaml, PyQt5.QtNetwork, PyQt5.QtQml, PyQt5.QtSql, PyQt5.QtOpenGL, PyQt5.QtDBus, PyQt5.QtWebChannel, PyQt5.QtWebEngineCore, PyQt5.QtPrintSupport, PyQt5.QtWebEngineWidgets, PyQt5.QtWebKit, PyQt5.QtWebEngine (total: 16)

I was about to link you to a thread at Reddit hoping it would have a solution, then I saw it was yours.

What happens if you pacman -Rsc qutebrowser then reinstall? Just double check what you are removing when running -Rsc.

I did a full uninstall then reinstall, no errors, but nothing changes, I still get the above error when trying to run QB. Somehow I did screw up the QT platform, but only for QB I think because for example I have Whatsapp installed, a QT version of it and that’s running without problems…

Check the dependencies for Qutebrowser at the Arch Package site and you may need to reinstall the related QT packages.

https://archlinux.org/packages/community/any/qutebrowser/

I did reinstall all this packages, nothing changes ffsk :frowning:
image

Did The Compiler have any advice?

Nothing that worked yet…maybe @natemaia can give some advice when he comes on…

Are you installing qutebrowser from the Arch repos, or qutebrowser-git from the AUR?

Tried both a couple of times, exactly the same crap happens. I’m almost sure it’s not QB’s fault, I must’ve have done something to python or qt or both :frowning:

1 Like

At this point I have to quit any hopes of using QB anytime soon as I don’t plan to reinstall my AL if everything else works on it. I know it’s my fault, I did something with QT and/or python to screw it up but it looks that I’m not capable enough to fix this specific issue. :((

Please post results from Terminal of the other way that you installed it., someone might be able to help you out @drLobes

Also, what happens if you either remove or update reinstall those packages, then try reinstalling Qutebrowser:

lib32-mesa-21.0.2-1 mesa-21.0.2-1 qt5-base-5.15.2+kde+r171-3

Super cool guy The-Compiler, he took the time to dig deeper and help me get my QB back :))

Could you show the output of running this with python3 ? Untitled - the-compiler.org-pastebin

[x@archlabs tmp]$ python3 test.py
sys.version = ‘3.10.4 (main, Mar 23 2022, 23:05:40) [GCC 11.2.0]’
sys.executable = ‘/usr/bin/python3’
qVersion() = ‘5.15.3’
QT_VERSION_STR = ‘5.15.2’
PYQT_VERSION_STR = ‘5.15.6’
QtCore.file = ‘/usr/lib/python3.10/site-packages/PyQt5/QtCore.abi3.so’
QtWidgets.file = ‘/usr/lib/python3.10/site-packages/PyQt5/QtWidgets.abi3.so’
QLibraryInfo.location(QLibraryInfo.DataPath) = ‘/usr/lib/python3.10/site-packages/PyQt5/Qt5’
QFactoryLoader::QFactoryLoader() checking directory path “/usr/bin/platforms” …
qt.qpa.plugin: Could not find the Qt platform plugin “xcb” in “”
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Aborted (core dumped)

And this is the part that solved my problem, maybe some day it will be useful to someone, long story short, DO NOT EVER EVER do this, like I did :)) “sudo pip install PyQt5”…

Why do you have a /usr/lib/python3.10/site-packages/PyQt5/Qt5? That’s not an Archlinux installed Qt. It sounds like you did sudo pip install PyQt5 at some point, which is a really bad idea.

Next thing I’d try is sudo pip uninstall PyQt5 PyQtWebEngine, see if you find any other non-pacman-installed files there (find /usr/lib/python3.10/site-packages/PyQt5 | xargs pacman -Qo > /dev/null), and then reinstall python-pyqt5 and python-pyqt5-webengine. Perhaps repeat the same thing for your entire /usr/lib/python3.10/site-packages to find out what else you installed with sudo pip install too… (can ignore __pycache__ stuff).

4 Likes

The Compliler is the man. Great to see you are sorted.

3 Likes