ArchLabs Linux

Conky Issue

Any conky guru know why conky has suddenly decided I need to displays of mpd_elapsed and mpd_length showing? Only one actually works, the other one just sits at 0:00 - 0:00.

img-2020-01-21-180001

My Config:

conky.config = {
--##  Begin Window Settings  #####################
own_window = true,
own_window_type = 'override',
own_window_transparent = true,
own_window_argb_visual = false,
own_window_class = 'conky',
own_window_hints = 'undecorated,sticky,skip_taskbar,skip_pager,below',
--## ARGB can be used for real transparency
--## NOTE that a composite manager is required for real transparency.
--## This option will not work as desired (in most cases) in conjunction with
--## own_window_type normal


--## When ARGB visuals are enabled, this use this to modify the alpha value
--## Use: own_window_type normal
--## Use: own_window_transparent no
--## Valid range is 0-255, where 0 is 0% opacity, and 255 is 100% opacity.
--own_window_argb_value 255

alignment =  bottom_right,
minimum_width = 1683,
maximum_width = 1683, 
minimum_height = 280,

gap_x = 3900,--## left | right
gap_y = 10,--## up | down
--######################  End Window Settings  ###
--##  Font Settings  #############################
-- Use Xft (anti-aliased font and stuff)
use_xft = true,
font = 'Segoe UI Regular:size=8',


-- Alpha of Xft font. Must be a value at or between 1 and 0 ###
xftalpha = 1,
-- Force UTF8? requires XFT ###
override_utf8_locale = true,

uppercase = false,
--########################  End Font Settings  ###
--##  Colour Settings  ###########################
draw_shades = false,--yes
default_shade_color = '#1c2023',


draw_outline = false,-- amplifies text if yes
default_outline_color = 'black',

default_color = '#26211F',-- Black
color0 = '#282A2E',-- Grey
color1 = '#bf616a',-- Red
color2 = '#FDFDFF',-- Green
color3 = '#ebcb8b',-- Yellow
color4 = '#81a1c1',-- Blue
color5 = '#C0C0C0',-- White
color6 = '#4f4f4f', -- Grey
color7 = '#535c5c', -- Nixie Blue Grey
color8 = '#E6EBF0', -- White
color9 = '#1c2023', -- Blue


--######################  End Colour Settings  ###
--##  Borders Section  ###########################
draw_borders = false,
-- Stippled borders?
stippled_borders = 0,
-- border margins
border_inner_margin = 0,
border_outer_margin = 0,
-- border width
border_width = 0,
-- graph borders
draw_graph_borders = true,--no
--default_graph_size 15 40
--#######################  End Borders Secton  ###
--##  Miscellaneous Section  #####################
-- Boolean value, if true, Conky will be forked to background when started.
background = true,
-- Adds spaces around certain objects to stop them from moving other things
-- around, this only helps if you are using a mono font
-- Options: right, left or none
use_spacer = 'none',

-- Default and Minimum size is 256 - needs more for single commands that
-- "call" a lot of text IE: bash scripts
--text_buffer_size 6144

-- Subtract (file system) buffers from used memory?
no_buffers = true,

-- change GiB to G and MiB to M
short_units = true,

-- Like it says, ot pads the decimals on % values
-- doesn't seem to work since v1.7.1
pad_percents = 2,

-- Imlib2 image cache size, in bytes. Default 4MiB Increase this value if you use
-- $image lots. Set to 0 to disable the image cache.
imlib_cache_size = 0,

-- Use the Xdbe extension? (eliminates flicker)
-- It is highly recommended to use own window with this one
-- so double buffer won't be so big.
double_buffer = true,

--   Maximum size of user text buffer, i.e. layout below TEXT line in config file
--  (default is 16384 bytes)
-- max_user_text 16384

-- Desired output unit of all objects displaying a temperature. Parameters are
-- either "fahrenheit" or "celsius". The default unit is degree Celsius.
-- temperature_unit Fahrenheit
--################  End Miscellaneous Section  ###

update_interval = 1,

};

conky.text = [[
${color5}${voffset 50}
${offset 270} ${font SF Pro Display:size=7:regular}$mpd_title
${offset 270} ${font SF Pro Display:size=7:bold}$mpd_artist
${offset 270} ${font SF Pro Display:size=7:regular}$mpd_album

${offset 270} ${font SF Pro Display:size=5:regular}$mpd_elapsed - $mpd_length
]];

I’m using conky-git from the AUR. I tried a different version of conky to see if it was the conky-arch-luas version that was an issue but no luck, same prob.

Any help will be really appreciated.

I rebooted and now conky has put those values on the same line:

img-2020-01-21-181651

Commenting out the line just leaves the 0:00 - 0:00 showing.

This is beyond weird. I tried it with a 1.9v config and same issue.

# — SETTINGS — #
background no
update_interval 1
music_player_interval 1
cpu_avg_samples 2
net_avg_samples 2
double_buffer yes
no_buffers yes
text_buffer_size 1024
imlib_cache_size 0

# — WINDOW — #
own_window yes
own_window_type override
own_window_transparent yes
own_window_hints undecorate,sticky,skip_taskbar,skip_pager,below

# — BORDER — #
border_inner_margin 1
border_outer_margin 0

# — SIZE — #
minimum_size 1683 280
maximum_width 1683

# — ALIGNMENT — #
alignment bottom right
gap_x 3900 #left/right
gap_y 30 #up/down

# — GRAPHIC — #
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders no
#default_bar_size 40 8
default_shade_color 181818
#own_window_colour 292929

# — TEXT — #
use_xft yes
xftfont Sans:size=8
xftalpha 1.0
uppercase no
override_utf8_locale yes
default_color c0c0c0
# — LUA — #
#lua_load ~/Conky/bgcolor/bg.lua
#lua_draw_hook_pre conky_draw_bg


TEXT
${voffset 50}
${offset 270} ${font SF Pro Display:size=7:regular}$mpd_title
${offset 270} ${font SF Pro Display:size=7:bold}$mpd_artist
${offset 270} ${font SF Pro Display:size=7:regular}$mpd_album

${offset 270} ${font SF Pro Display:size=5:regular}$mpd_elapsed - $mpd_length

Installed conk19-lua-nv only to have the same issue. This is fucked up.

I can’t see why this is happening.

A reboot seems to have fixed it. I edited the conky and saved and all seems okay for now. Will mark this as solved by install conky 1.9 for now. Not 100% sure that is the actual solution though.

…and my issue is back but now its all items being displayed.

img-2020-01-21-194825

This is fucking me off. So I decided to install the standard conky package. Still no change to my original issue.

So fucking weird.

This is all the output I get from the terminal which looks pretty standard.

conky: desktop window (6d2) is root window
conky: window type - override
conky: drawing to created window (0xe00001)
conky: drawing to double buffer
conky: forked to background, pid is 2166

I followed @ohnonot from the BL Forum and ran conky like this conky -DD -c /path/to/conkyrc >/tmp/conkyrc.log 2>&1 &

I got this output in the log:

DEBUG(0) [/build/conky/src/conky-1.11.5/src/conky.cc:2513]: reading contents from config file '/home/dobbie/.conky/claypool-no-cover.conkyrc'
DEBUG(0) [/build/conky/src/conky-1.11.5/src/x11.cc:401]: enter init_X11()
DEBUG(0) [/build/conky/src/conky-1.11.5/src/x11.cc:482]: Fixed xinerama area to: 0 0 3840 2160
DEBUG(0) [/build/conky/src/conky-1.11.5/src/x11.cc:433]: leave init_X11()
DEBUG(0) [/build/conky/src/conky-1.11.5/src/x11.cc:642]: enter init_window()
DEBUG(0) [/build/conky/src/conky-1.11.5/src/x11.cc:482]: Fixed xinerama area to: 0 0 3840 2160
conky: desktop window (6d2) is root window
conky: window type - override
conky: drawing to created window (0xe00001)
DEBUG(0) [/build/conky/src/conky-1.11.5/src/x11.cc:992]: leave init_window()
conky: drawing to double buffer
DEBUG(1) [/build/conky/src/conky-1.11.5/src/core.cc:2031]: no templates to replace
conky: forked to background, pid is 2887

DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:149]: loading fonts
DEBUG(1) [/build/conky/src/conky-1.11.5/src/fonts.cc:94]: setting up fonts
conky: received SIGHUP, SIGINT, or SIGTERM to terminate. bye!
DEBUG(0) [/build/conky/src/conky-1.11.5/src/x11.cc:437]: deinit_X11()

Instead of commenting out the line, try removing it and any white space/blank lines at the end of the configuration. Do a:

killall -q conky

and then start the conky from a terminal.

How many instances of conky are normally running?

Did you do an upgrade right before this started?

Conky has a bug(s) where config files suddenly stop working and these annoying errors occur. On a couple occasions, I’ve had to rewrite the entire conkyrc and then conky magically works again.

2 Likes

@Dobbie03 Don`t kill me if i tell you totally nonsense, but i have had the exact problem in the past. 3-4 years ago. I think i have solved that with this: “own_window_argb_visual true”

But it can be thats total nonsense, cause its a long time ago, but i think i have solved that problem with that above.

2 Likes

Dobbie03 - using your conkyv1.9 conky I get:

Conky: MPD error: problems getting a response from "localhost" on port 6600 : Connection refused

Conky: MPD error: problems getting a response from "localhost" on port 6600 : Connection refused

Conky: MPD error: problems getting a response from "localhost" on port 6600 : Connection refused

How do you start songs?
can you link to a song that only shows cover art please or send me on.

Interesting I get that error with or without mpd running
but when running I get a pop-up black screen and sound

EDIT DUH I have mpv here not mpd got it now
Such a dunce

OFFICIAL: DUNCE
21 Jan 20 @ 09:31:26 /media/5/conky
$ mpd
errno: failed to open log file “/var/log/mpd/mpd.log” (config line 38): Permission denied

and that log file reads:
Jan 21 09:24 : errno: Failed to open /var/lib/mpd/state: No such file or directory

So until I figure our how to even run “mpd” i am stuck :frowning:

2 Likes

Thanks for your replies dudes. It’s decided to work correctly today. Gonna close this one up.

2 Likes