Configuration module Polybar network download, upload

hello everyone, I have a problem with polybar I can not set a module to see the download and upload of my network wlo1, I did a thousand tests and searched for everything but nothing to do, can someone help me?

If you start polybar from a terminal does it output an error message?

This is the module I use:

;; WIFI ;;
type = internal/network
interface = wlo1

; Available tokens:
;   %ifname%    [wireless+wired]
;   %local_ip%  [wireless+wired]
;   %essid%     [wireless]
;   %signal%    [wireless]
;   %upspeed%   [wireless+wired]
;   %downspeed% [wireless+wired]
;   %linkspeed% [wired]
; Default: %ifname% %local_ip%
;label-connected = %essid% %downspeed:9%
;label-connected-foreground = #eefafafa

;format-connected = "<ramp-signal> <label-connected>"
format-connected = "  <label-connected> "
format-packetloss = <animation-packetloss>
label-connected = %signal%% %upspeed:2% %downspeed:2%
;label-connected = %signal%%

ramp-signal-0 = 
ramp-signal-0-foreground = #F03051
ramp-signal-1 = 
ramp-signal-1-foreground = #F07127
ramp-signal-2 = 
ramp-signal-2-foreground = #F9CE56
ramp-signal-3 = 
ramp-signal-3-foreground = ${colors.purple}
ramp-signal-4 = 
ramp-signal-4-foreground = ${colors.purple}
ramp-signal-5 = 
ramp-signal-5-foreground = ${colors.purple}

animation-packetloss-0 = ⚠
animation-packetloss-0-foreground = #ffa64c
animation-packetloss-1 = 
animation-packetloss-1-foreground = #000000
animation-packetloss-framerate = 500

shows the signal strength and up/down speeds:

1 Like

Hi Packrat, I tried your configuration and it gives me this error:

polybar i3-bar
error: Disable module “wireless-network” (reason: No built-in support for ‘internal / network’)

I forgot about that - same issue in this thread

The internal/network has a bug or wasn’t compiled into the Arch package for polybar. You’ll have to compile your own package, or go with a custom script to get network speeds.

Edit - appears that networking is not compiled into the Arch (AUR) build:

polybar -v
polybar 3.1.0

Features: +alsa +curl +i3 +mpd -network

1 Like

It’s just that the problem, I tried to reinstall both polybar and wireless-tools but always gave the same problem, I solved by installing polybar da aur version 3.1.0-4
Thank you for your availability and help :wink:

Is that a different AUR or a typo?

I only see polybar and polybar-git in the aur.

Polybar, not the git

1 Like