Compton doesn't work with pywal


#22

I was able to restore transparency with wal -a "50" -i [path] for a moment but it doesn’t work anymore for some reason.
I’m trying to figure out what is wrong. (EDIT: when I tried to do this again I had a typo, AGAIN… grrrr…

EDIT: With Compton running, I can set the color scheme + transparency with

 wal -a "any number" -i path/to/image


Look at those glorious transparent terminals!

In the future when I’ve changed my wallpaper to something else, where should I store this wal command for easy access and modification?
I’m not sure how Archlabs handles the booting of programs and I’d like my colour scheme to be set when I hit Login.
I’m 100% fine with editing the config file when I choose to change the wallpaper and I want a different color scheme.
If there’s a better way to do this, please tell me.

Pretty much this mess is all because I was unaware of the -a flag of pywal… haha.


#23

You can put launch commands for login in ~/.xprofile, or you can add it to your i3 config like

exec --no-startup-id wal ....

#24

I only saw it from your last screenshot where it was run with an error and output the help info :stuck_out_tongue:


#25

Seems wal has you covered there

  -R                    Restore previous colorscheme.

use that as your startup command, then when you change themes it will just reload the last ussed.


#26

Alright, I will try that out when I get home from work later today and after that I will mark the thread solved if nothing else pops up.

Hahaha, I’ve used pywal for a close to a year now(?) and I just now learned about the -a flag!
It is actually the first time ever that I’ve actually required to use that flag.
I’m pretty sure that my system is all-ok on this part but do you have any info why am I required to use that flag?
Also I’ve always used wal -i [path/to/image] on startup so thanks for bringing up the -R flag.
Saves time and typing.

I feel dumb but educated :smiley: .

More and more I feel as if all of this could have been prevented if I would have just RTFM a bit more closely.


#27

XD yea sometimes I open with that… but those are my off days


Yea this has nothing to do with your system, the reason it’s needed is because wal sets the colours using xrdb and in urxvt’s case it’s configuration ( [XX]#XXXXXX ) is non-standard so wal has a special flag for it. urxvt is a fiddley terminal in many ways and contains a lot of legacy code as well as breaking xterm compliance in many cases.