Changing GTK Themes


#1

Hey guys, can’t seem to change the GTK theme in my i3wm instance. I have ArchLabs Light selected, but everything is still set visually to ArchLabs Dark, despite mod+shift+r and a reboot. Thought?

~/.config/gtk-2.0/gtkfilechooser.ini

[Filechooser Settings]
LocationMode=path-bar
ShowHidden=false
ShowSizeColumn=true
GeometryX=0
GeometryY=0
GeometryWidth=840
GeometryHeight=630
SortColumn=name
SortOrder=ascending
StartupMode=recent

~/.config/gtk-3.0/settings.ini

[Settings]
gtk-theme-name=ArchLabs-Light
gtk-icon-theme-name=ArchLabs-Light
gtk-font-name=sans 11
gtk-cursor-theme-name=ArchLabs-Light
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=0
gtk-enable-input-feedback-sounds=0
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintslight
gtk-xft-rgba=rgb

~/.gtkrc-2.0

# DO NOT EDIT! This file will be overwritten by LXAppearance.
# Any customization should be done in ~/.gtkrc-2.0.mine instead.

include "/home/user/.gtkrc-2.0.mine"
gtk-theme-name="ArchLabs-Light"
gtk-icon-theme-name="ArchLabs-Light"
gtk-font-name="sans 11"
gtk-cursor-theme-name="ArchLabs-Light"
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=0
gtk-enable-input-feedback-sounds=0
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintslight"
gtk-xft-rgba="rgb"

#2

Use either LXDE Appearance of XFCE4 Appearance Settings


#3

Thank you, LXDE Appearance would not accept changes, but XFCE4 did.