Changing default font sizes [ArchLabs bspwm]

Hi all, I’ve searched quite a bit for solutions to this issue I’ve had due to my laptops monitor geometry the past couple years, and thought maybe you could help.

I’m loving the bspwm install so far. I have a 1920x1080 monitor on a 14" laptop, though, so certain things are a little too small. Tint2 fonts are small, as are default firefox and jgmenu fonts. I can easily change the terminal font for termite, so no issue there. I can change the size of the tint2 panel as well, but font size changes for jgmenu and tint2 in their rc files don’t seem to have an effect.

When I used KDE I had no issue, as it was able to implement a forced dpi of 120 and it was more or less implemented with few exceptions.

I’ve tried xrandr --dpi to set a dpi of 120, which in my experience with Win10 worked well, and have tried xft.dpi: 120 in .Xresources but neither have had an effect, even after logout or reboot. What is the most effective way to fix this issue? I understand not all applications will use .Xresources or xrandr settings, but there has to be something I’m not seeing.

Thanks in advance for your advice.

Hi jack and welcome on the forum,
I’m not a jgmenu/tint2 user but I’m a Bspwm fan and I’m quit sure WM as nothing to do with font size, can I recommand you the dedidated thread ? JGMENU or maybe this ONE. :wink:
ps: a pastebin jgmenurc

1 Like

Thanks, very helpful for fixing jgmenu fonts. For some reason I was editing a different jgmenurc file that wasn’t actually the one being used.

I think I figured out the answer to my own issue. xfsettingsd isn’t normally running after a default install with bspwm as the only wm. Setting it to launch in .xprofile enables the dpi scaling (as well as all other appearance settings) available in xfce4-settings. I was going crazy trying to figure out why changing these settings was having no effect. Problem solved.

The downside is that when xfsettingsd is running, the super key is bound to xfce4-popup-applicationsmenu, which is not installed (nor really needed in the case of a bspwm setup). Had to rebind the default rofi launcher to super-space and am avoiding hitting super until I can figure out how to fix this.

Can grab the xfce configs from the xfce4-skel package and overwrite your keyboard-shortcuts.xml in ~/.config/xfce/...


Super helpful, thank you.