Changing default font size

I use lxappearance to change the fonts but it seems there are default system fonts somewhere which are independant of such customization. How do I know for sure? Beause my chromium address bar never changes it’s font, and I’ve found that chromium uses default OS fonts in this caze.
Then, I’ve found about the /etc/fonts and ~/.config/fontconfig directories om ArchWiki, and I’ve searched them all, but there are variables for the font types only, no “font size” at all.
And I am not able to find anything else about this topic. Is there a way to change default ArchLabs font size?

Use the xfce4-settings-manager and choose Appearance.

You will also need to change the fonts in obconf, assuming you are using Openbox.

xfce4-settings-manager didn’t help, at least the address bar is still the same (now I’m using Brave).
And I am not using Openbox, I am using bspwm with lightDM.

make sure that xfsettingsd is in your autostart. Run xfsettingsd just in case the daemon hasn’t started correctly.

I assuming (again assuming :slight_smile: ) that you have xfce4-settings-manager installed and that you haven’t swapped it for lxappearance?

How do I do this?

Nothing changes.
image

Yes, I tried it but soon I realized that I should change lightDM for lxsession which I don’t want to do. If it’s possible to solve the issue without lxappearance, I’d be glad to do so.

Are the fonts changing for the other applications you use?

Are the fonts in the Chromium address bar too large? that was a long standing issue.. Is there a setting in Chromium settings specific to the address bar?

Yes, they are.

No, they are too small, and there is no setting for address bar specifically.
Furthermore, to make the content size appropriate, I should apply the “zoom 150%” setting, no other way, while in Windows OS, the default 100% zoom is comfortable enough. I cannot understand on what that depends.

I just can’t not to share what I’ve got. That’s rather funny.
Put aside I have all my gtk-3.0 and gtk-2.0 settings ok like that
image

I’ve finally tried this.

This has changed my greeter font and even boot loader font (!).

But my chromiums are unshakable (attention to the address bar, it’s still as weeny as it was at the beginning).
image

Both chrome and chromium allow doing this (if in a slightly obscure manner)

First open the browser, open chrome://settings/appearance and make sure you enable

  • Use system title bar and borders
  • GTK+ theme

eg.

Now the GTK font you set (through lxappearance, xfce-settings-manager, or just editing the gtkrc files) will be used for the titlebar and tabs

You can see I set Serif 6 as the font and my browser has the same (only after closing and re-opening it though)

Hope that helps, cheers


EDIT: after some tests I think you actually can use the “Classic” theme, just the system borders bit is required. My mistake.

These options were already enabled, first and last ones on the screen. Brave though, but that doesn’t matter, it’s literally chromium.

I have a guess that the chromiums take a system font value when they are installed, and then just save it and go with it.
Now I will try to install vanilla Arch, I want to play with it from zero, and I’ll set the font size beforehand, so we’ll see if it’s going to be different.

Yes. This is my issue with Chromium over FF. I have had a hell of a time getting Chromium fonts correct.

Do you have some custom css that might be affecting it? I had to install and change one setting, if there is more involved than that I would please post examples.

I cannot speak for brave as that was not mentioned in the original post but I can check it out

No, I didn’t add any custom css, that’s a vanilla browser from the repository.

Ok the same settings apply for all three but it won’t have any effect on the address bar.

Try

brave --force-device-scale-factor=2

Need to not have any other instances running as far as I can tell or it will use their scaling.

scale at 3

scale at 1

It works, but only one-time. How do I save this setting?
I tried to add the following to /usr/share/applications/brave-browser.desktop

Exec=brave --force-device-scale-factor=1.5

But for some reason that doesn’t work, but works when the string above is just put into the terminal.

UPD.: Wait a minute, it doesn’t work already. Probably the value is incorrect. Strange. I bet it worked.
I get it, it works only from the terminal and only when no other windows are open, it doesn’t work when nothing is open not from the terminal.

As mentioned above


How are you launching the .desktop file?

Hm, I am launching the web browser with super + w, and that just opens the browser which is set in the “preffered applications” in xfce4-settings-manager.
Where do I put this line to make it work?

Ok this is what I got to work for me.

First create a small shell script somewhere to run brave with whatever arguments you like

echo -e "#!/bin/bash\n\n/usr/bin/brave --force-device-scale-factor=2" > ~/.local/bin/brave
chmod +x ~/.local/bin/brave

Make sure that ~/.local/bin is on your PATH, for bash this will be in ~/.bash_profile, zsh ~/.zprofile

# add this line somewhere near the top of your profile
export PATH="$HOME/.local/bin:$PATH"

Now just running brave or the exo-open --launch WebBrowser will run the brave script instead of the executable /usr/bin/brave because we named them the same but our local bin is first on the PATH.

EDIT: You will have to logout for the profile to be loaded by your login shell. You can also set the PATH system wide in /etc/profile instead but it must use an absolute path eg.

PATH="/home/nate/.local/bin:$PATH"
# just replace my username with yours