Change Mouse Cursor size

My notebook is connected to an external 32" monitor and after reboot and logging into openbox the mouse cursor is huge. How to prevent the unusual huge size and how do I change it?

I have this in my .Xresources:

Xcursor.size: 32

Just a reminder I use 4k res so you may need to make that smaller. It will stay the same size on your notebook so it’s not a dynamically changing cursor.

That didn’t solve it. I still try around. What’s the root of the problem, I can’t figure out? Is it from Openbox? X? GTK something? Is it because of some scaling because using an external monitor?
I didn’t customize my GUI nor Openbox.

Also checked if the setting was set to “visually impaired” people mode, but nothing.

EDIT: When I reboot without ext. Monitor, the cursor has the right size, so I conclude it is something that happens when an ext. Monitor gets connected. :frowning:

EDIT 2: Ok. After logging in I reconnected the notebook to the docking station. Then I tried haphazardly a richt-click–>Openbox–>Openbox Resatrt. Now the cursor is normal in the desktop area, but huge once the cursor moves into e.g. FF or Terminal Window.

That’s bizarre. Does your system have defaults set depending when it’s in dock and when it’s not?

Shit man, that fixed my issue. Time for a google search. Will report back.

EDIT, quick thought, have you adjusted the cursor size in the Mouse and Touchpad settings?

@sevenday4
It’s default, yes.

@Dobbie03
Where do I set the cursor size please? Touchpad-Settings I did not touch.

Open Mouse and Touchpad settings, in the theme tab change your cursor size.

Set to 16 points. Nothing special.

What type of video card, and the driver you’re using?
You connect the laptop to a docking station, how is the external monitor connected?

Those were my next questions. Something is triggering the display settings is where I am leaning to.

Ok. Here we go. It’s a Intel® Core™ i5-6200U CPU @ 2.30GHz. THe monitor is connected via the Docking Station (HP 32z something). I think it has something to do with some scaling. Somewhere is something that tries to use the main Monitor’s size and does not adapt to the external monitor? There is some validation problem between the devices and how to scale the cursor.

Sometimes I noticed a strange behavior, that the normal cursor stays small when strolling around and well sized, but if you try to move a window, then the “grabbing hand” rescales somehow and becomes huge.

Good night then… Pheew…

Are the laptop and external monitor set to the same resolution? Can you do that if they aren’t.

Google wasn’t much help on this one.

The monitor’s resolution: 3840*2160 connected per Docking Station and Displayport

The Craptop’s resolution: 1920*1080

The same resolution was possible. On the notebook the cursor was pretty huge afterwards, as well as on the ext. monitor. But on the ext. monitor the cursor was slightly bigger. Strangely, when opening a Terminal window on the Laptop, the cursor was big, but shrank to the right size it should have when moving it into the terminal window. Moving it out again, the curosor was huge again.

EDIT: Again. Open any window–> move cursor in --> huge curse-or
Move out --> Curse-or shrinks to correct size.

EDIT 2: Looks like a bug. Should the post be moved to the correct category?

Let’s see how we go. Has Google produced any results or options to try?

Cursor size problems when using second monitor

This one… Seems to be my problem, too.

So is the reported DPI the same in the monitor and the laptop?

Have you tried an Xorg configuration file to set the screen dimensions?

Have you tried arranging the screens side-by-side?

1 Like

I’m trying some things. Well, but still no solution.

  • Added Xcursor.size: 32 to .Xresources and rebooted. Didn’t help.
  • Started Laptop without Docking Station. Then connect, expand Desktop via Application called “Display”. Didn’t help.
  • Started Laptop with Docking Station. Then configured the ext. Displ but … Didn’t help
  • Checked settings in Mouse & Trackpad. All default.
  • Rebooted. Tried to re-arrange Desptops in many a way (Left-Right, Right -left, Atop-Bottom, Main Screen to ext. and turn off Laptop and vice versa) via ARandR instead of “Display”-Application but also with “Display”. —> Didn’t help.
  • Checked Appearance Settings of Openbox. All is default.

What I don’t know is, which way to go to set the DPIs?
EDIT: I did not touch/create a Xorg configuration.

My Gfx-Card:
    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07) (prog-if 00 [VGA controller])
        Subsystem: Fujitsu Limited. Skylake GT2 [HD Graphics 520]
        Flags: bus master, fast devsel, latency 0, IRQ 129
        Memory at e0000000 (64-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 3000 [size=64]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

Editing or creating an Xorg.conf is yet beyond my knowledge. Can I break something?