Certain keys not always working

Hi,
My keyboard has started to lay up on my lappy :frowning:

It seems to be certain keys (back space, ! mostly) but also others (it just happened on p, hence ‘lay’ and not ‘play’ above)
But its an intermittent problem
I had it a few days ago then it seemed to go away, but now its back again
Its also intermittent in the sense that if a key doesn’t work then doing it again sometimes works, or typing more slowly - the latter especially works

Before I look into this and disassemble my (2014 ASUS X5550LB) lappy to blow out the keyboard etc, is there anything non-hardware that it could be?

from my mechanical experience it just doesnt ‘feel’ like its the hardware keyboard giving in (why did it happen at various parts of the keyboard all at the same time, why does it sometimes work and sometimes not, etc?). Of course, wishful thinking could be an issue here LOL

It feels to me that something software is making the keyboard become unresponsive - like when an app flips out a bit and the keyboard becomes unresponsive for a short time.

I am not sure if it is app specific. I know it has happened in the terminal (but, for example, ! and backspace are currently working fine in terminal)

Thanks

Time to plug in a USB KB. It least you can see if it’s hardware or software. Who knows, you might like the feel of a real KB.

3 Likes

Could it just need a good clean with some compressed air? Maybe there are crumbs or dirt inhibiting the key stroke?

2 Likes

Could be, but very suddenly happened in different areas of the keyboard

It just got worse, typing in Firefox, with ", P, back space and a few others not working
So I opened up a terminal and the same keys were not working
But then when I shut Firefox they started working in the Terminal
And now that I have reopened Firefox those keys are working again, look:
"p the next word had been deleted
strange

1 Like

Will do, but space limited on my desk, I need the lappy screen, and I dont like clutter LOL
Also, see below, as it seems to be connected with Firefox? Maybe. Perhaps

Weird indeed. Maybe a hardware fault? Maybe time to use an external keyboard as @eight_bit_al suggested?

2 Likes

I have tried with an external keyboard this morning and the problem did not occur with it
However, since then (its now late afternoon) I have been working on the lappy without the external keyboard (i.e. using the Lappy’s keyboard) all day without any problems whatsoever

oh well, seems to have cured itself (famous last words)
I’ll blast it out with compressed air at the lab tomorrow anyway

1 Like

The threat of a replacement set the KB straight.

4 Likes

I felt it tremble

I use a separate KB even though ThinkPads are considered to have good KBs.

All my life, friends have brought me broken things to ‘look at’. Countless times I’ve disassembled the thing, found nothing wrong, reassembled and it worked fine.

Try using xev (package is xorg-xev on Arch), it will output a lot of info and it’s a bit of eye-parsing to get the info you want but it’s the program to use to find xorg input readings. If you don’t get consistent results from that then it’s likely your keyboard. Replacement laptop keyboards are and easy fix and usually not hard or expensive to find. I agree with @eight_bit_al in this case, get a nice dedicated keyboard and enjoy escaping the chiclet garbage :smiley:

3 Likes

One of my good friends has the exact same red dragon board, they’re not amazing but jesus the price to performance is through the roof. With some MX blues they’re actually not a bad typing board, and small.

1 Like

I’ve posted about this before
Can I simply convert this to USB (as in, if I get a physical adapter will it work?)


Having said that, all seems fine now
xev was already installed
seems to give what it should do for all keys

You must be living close to the British Museum? I guess the adapter will be more expensive than a new clickety-clack :joy:

Throw that out Leigh

:rofl: I like old stuff

I dont throw stuff out - why would I when I have mum and dad’s loft :smiley:

Honestly though, my desk works so well with the external monitor at the right height and the lappy screen just below - and like that there is no room for an external kb.

2 Likes

Just to tidy up
It started to happen when dual booted into windows too and spread a bit to other keys
I just got the Isopropyl alcohol spray and my Henry hoover on the job and its seems to have worked :smiley:

Well, nothing like a good cleanup sometimes.

1 Like