Can't update system

Hi, for some days i haven’t power on my laptop and now there are 333 Updates.
So i run updatemanager (pacli) and hit number 1. He’s doing something and than this message is in pacli:
:: Installation fortsetzen? [J/n]
(337/337) Prüfe Schlüssel im Schlüsselring [------------------------------] 100%
(337/337) Überprüfe Paket-Integrität [------------------------------] 100%
(337/337) Lade Paket-Dateien [------------------------------] 100%
(337/337) Prüfe auf Dateikonflikte [------------------------------] 100%
Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
js52: /usr/lib/libmozjs-52.so.0 existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

So it means there are some conflicts with installed files. How could i solve this?

1 Like

@ernestoo Das hier sollte deine Lösung sein:

1 Like

Hey danke, der Fehler kommt nicht mehr, dafür nu dieser:
sudo pacman -Syu
:: Synchronisiere Paketdatenbanken…
core ist aktuell
extra 1610,1 KiB 3,26M/s 00:00 [----------------------] 100%
community 4,4 MiB 9,14M/s 00:00 [----------------------] 100%
multilib 171,9 KiB 56,0M/s 00:00 [----------------------] 100%
archlabs_repo ist aktuell
:: Starte vollständige Systemaktualisierung…
:: deepin-wm-switcher durch community/startdde ersetzen? [J/n]
:: libbson durch community/mongo-c-driver ersetzen? [J/n]
:: libmongoc durch community/mongo-c-driver ersetzen? [J/n]
Löse Abhängigkeiten auf…
Suche nach in Konflikt stehenden Paketen…
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: ffmpeg2.8: das Installieren von x265 (2.8-1) verletzt Abhängigkeit von ‘libx265.so=151-64’

@ernestoo Ja, den hatte ich eben auch. Entferne einfach ffmpeg 2.8. und update neu. Dann sollte eigentlich alles klappen.

Info: https://forum.antergos.com/topic/9384/update-problems

1 Like

Hmm, ne nun bekomme ich diese meldung:
(339/339) Prüfe auf Dateikonflikte [------------------------------] 100%
Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
js52: /usr/lib/libmozjs-52.so.0 existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Ich vermute das sind Mozillasachen, aber mozilla kann ich nicht deinstallieren.

Okay, es läuft nun. Habe die Datei manuell gelöscht.

1 Like