Cant startx


#1

Hello

I just installed archlabs and then rebooted the system. After entering my username and password I was greeted to the screen velow. But I cant seem to login pls help. I have tried startx and everything to no result. Please help.


#2

What window manager did you select during the install?

What - if any - is the error message after you tried startx?


#3

Openbox is the window manager.


#4

Did you pick openbox or xfce?

The above you say openbox but it’s clearly trying to start xfce4.

What is the output from

which openbox
which xfce4-session

To install xfce run

pacman -S xfce4 xfce4-goodies

To install openbox run

pacman -S openbox obconf

Did you actually pick one to have installed, perhaps something just went wrong when installing the packages


#5

We’ve had the problem before frankly, I’ll begin searching for it. @mrneilypops was who directed me to the solution.

Hang in there

** I’m searching… @natemaia it was regarding the 2018.07.26 testing iso. I can’t find what I’m looking for but remember this distinctly

**Edit 2 found what I was searching for (unfortunately not sure if it will help here)
check here

Sorry man, see below


#6

@Karan35 If it was me… Reinstall by selecting either openbox or xfce and once in x, install another.

Had a simular experience while testing the release but in my case, I tried installing cinnamon and three WM.

If you plan on installing multiple wm or de’s, select lightdm when prompted by the installer (for your convenience).


#7

I selected openbox as wm and xfce as terminal option.


#8

But I only selected openbox when asked about wm and xfce4 when asked about terminal. Then I was presented with option of either xinit or lightdm so I selected xinit. That’s it.


#9

So what to do now??


#10

It worked. I put xfce4 commands and it booted. Thanks BTW can I opt for openbox over installed xfce4?


#11

Awesome, apologies for the issue during install I’ll look into it.


Yes of course, edit your ~/.xinitrc

# change this line
exec startxfce4

# to this
exec openbox-session

Then log out and when logging in and run startx openbox will run (make sure you have it installed with the commands I posted before).


#12

Watch out. That’s a slippery slope towards i3.


#13

It sure is. I installed ArchLabs with openbox but after an hour or so working in it I found out that I can no longer get used to using windows. I reinstalled my backup and am happely working in my i3 install. It has a learning curve but it sure is worth it! (imho)