Can't interact with live environment

Hi,

On the latest live iso (2018.6) and also on the previous release (2018.5.1), I cannot interact with the live environment. Neither my wireless mouse nor my keyboard has any effect.

Both ISOs were written to usb with the normal mode and with DD. I also used etcher and Rufus to make the usb installation media.

Thanks for any help,

Rob

1 Like

Well, same here.
Buy when I start from a root tty, I can do everything, even install.
I`ve installed Archlabs from a live usb with a root tty and the script, but after the reboot, I can do nothing with the user created at the installation…

So, just found out that it was a compton issue.
I reinstalled the entire system.
Got into live session, go to another tty, kill compton process and install.
After the install, reboot, open another tty, kill compton process again, edit the config file and enjoy.

Here’s an example:

# Shadow
shadow = true;
no-dnd-shadow = true;
no-dock-shadow = true;
clear-shadow = true;
shadow-radius = 8.0;
shadow-offset-x = -7;
shadow-offset-y = -7;
shadow-opacity = 0.60;
shadow-ignore-shaped = true;

# Opacity
menu-opacity = 1.0;
inactive-opacity = 1.0;
inactive-opacity-override = false;
alpha-step = 0.06;

# Backend
backend = "xrender";
mark-wmwin-focused = true;
mark-ovredir-focused = true;
detect-rounded-corners = true;
detect-client-opacity = true;
refresh-rate = 0;
vsync = "opengl";
paint-on-overlay = true;
unredir-if-possible = true;
detect-transient = true;
detect-client-leader = true;

# GLX backend
#glx-no-stencil = true;
#glx-copy-from-front = false;
#glx-use-copysubbuffermesa = true;
#glx-no-rebind-pixmap = true;
#glx-swap-method = "undefined";
#glx-use-gpushader4 = true;
#xrender-sync = true;
#xrender-sync-fence = true;

opacity-rule = [
	"80:class_g = 'XTerm'",
	"0:_NET_WM_STATE@:32a *= '_NET_WM_STATE_HIDDEN'"
];

shadow-exclude = [
	"name = 'Notification'",
	"class_g = 'VirtualBox'",
	"class_g = 'Conky'",
	"class_g ?= 'Notify-osd'",
	"class_g = 'i3-frame'",
	"class_g ?= 'cairo-dock'",
	"class_g = 'Cairo-clock'",
	"class_g ?= 'Cairo-dock'",
	"class_g ?= 'plank'",
	"class_g ?= 'Docky'",
	"_GTK_FRAME_EXTENTS@:c"
];

focus-exclude = [
	"class_g = 'Cairo-clock'",
	"class_g *?= 'Virtualbox'",
	"name *?= 'Authy'"
];

invert-color-include = [
];

fade-exclude = [
];

# Window type settings
wintypes:
{
  tooltip = { fade = true; shadow = true; focus = true; };
};
no-fading-openclose = false;
frame-opacity = 0.0;
blur-background-fixed = false;
1 Like

Hey thanks for the information, but I’m not sure I can get a tty in live environment since no keystrokes are registering…

I will give it a shot tonight though.

1 Like

So I tried to access a tty while in the live environment, but nothing worked. The only thing that I can do is move the cursor with the mouse. It’s as if my keyboard isn’t even connected. My keyboard works fine in my other OS.

Anyway, I’m going back to the March install iso…

1 Like

Might be the best thing to do here.(March install iso)

Post from terminal:

inxi -Fxz

Someone might give you a hand, might be able to do something concerning hardware, never know.

1 Like

No crtr+alt+f2?

Sorry…yes… the correct keys to press for a tty slipped my mind. So I can get a terminal, but now it’s asking me to login…

1 Like

user: root
password: archlabs
On the tty you should be able to kill compton process and start a X session.

$ sudo pkill compton
$ startx

Then you can mess arround or just go straight to the install

$ al-installer

Good luck! :slight_smile:

1 Like

Thanks Orcololo, Archlabs is up and running!

2 Likes

I have this issue with one of my 3 PCs at home. I am hopeful this will solve the problem…, thanks for posting.

1 Like

I was able to install livecd BUT locks up at the last step on boot loader install… same problem on last 2 iso…

1 Like

Did you disabled compton?

thanks for the reminder, after disabling compton was able to finish install properly.

However I always seems to end up with a colorful prompt and have to type in “startx” to get into the opening graphic screen. Looked into ~/.xinitrc and tried to install lightdm but without success. Any help?

1 Like

Did you enabled lightdm?

sudo pacman -S lightdm
sudo systemctl enable lightdm

?

2 Likes

^yep!

1 Like

I followed orcololo’s instructions on editing compton configuration. I killed compton, installed archlabs, rebooted, then killed compton again, and then edited compton configuration as orcololo posted above. Then I rebooted and ran AL-Hello script and installed lightdm. This was using the June ISO. I never had to use startx after this.

2 Likes

yes, sudo systemctl enable lightdm.service…

thanks for the input.

2 Likes

@orcololo, good catch man :slight_smile:

2 Likes

@anon37345411 ty! :slight_smile: