Can't Install ArchLabs

Hello there, new member here. Despite the new ISO I’m still unable to properly install AL. Other than following the installer to a T, I have no idea what I’m supposed to do. Any help is greatly appreciated.

List any error messages, or clearly tell us what the problem is.

And welcome to the forum.

1 Like

I’ll open this in a new thread.

Please share any error logs or feedback from the installer.

1 Like

It says
error: archlabs-ly: signature from “Nathaniel Maia natemaia10@gmail.com” is unknown trust
:: File /var/cache/pacman/pkg/archlabs-ly-0.5.3.2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature))

Press Enter when ready to continue to error dialog

I tried both normal and LTS ISOs.

I don’t know how to edit my posts… :sweat_smile:

If I don’t abort the installation it continues showing errors of the same nature and eventually when I reboot I can’t even login in what I suppose would be a broken system.
All this is very strange because, I kid you not, I installed ArchLabs without problems last week but then resumed my hopping. Now I wanted to go back to it because the Openbox offering was the lightest I tried but can’t. Distrohopping is seriously dangerous after all…

It’s weird. The new release should have fixed the key issue.

  1. download the latest iso image
  2. verify the image then try to install again
1 Like

Was the iso from that exact link @riyu

https://archlabslinux.com/get/

Uh, yeah I got the ISO from the official site → SourceForge. I’ll download it again then.

Make sure you verify the ISO file once downloaded is completed.

3 Likes

That should have been fixed. You are definitely using the 2022.10.15 ISO?

Yes, of course I’m using the latest ISO.
I don’t know why is it working for other people but not for me, I’m just following the installer, I’m not doing anything special.
Unfortunately I think I’ll have to give up for now and come back to this later.

Concerning the last attempt that you did, was that LTS or the regular iso version, wonder if it s hardware related at that point.

If you check on these commands from @chroot s post in another thread, what it does;


pacman -Sy && pacman -S

Latest attempts were done all with the “standard” ISO.
I don’t know if it can be a hardware issue but at this point I wouldn’t exclude anything

Well then, let me fire up the thing one more time and I’ll report back.

Ok, we ll see, & please post results here, it might help somewhat.

Also, do you have another install with that one that you attempt to make also !

Or it can be BIOS related also.

What did you have installed beforehand.

It synchronizes the package databases to 100% but there’s an error
error: no targets specified (use -h for help)

That s a good start then.

Oh, it might be partition related .

Currently there’s nothing installed, previously I tried vanilla Arch.