Can't install archlabs to usb-stick


#21

great! I’ll try that. thanks!


#22

Hi! So using your method I was able to go through the install process, but during the install I got an error message along the lines of “Error: could not load filesystem” or something like that in the middle of the block of text. I was able to go through the rest of the setup just fine, but when I went to boot I was greeted by

I formated the drive and went through the entire install process again, but the exact same happened.


#23

I think it’s a problem with the microcode did you install it?
but wait @matemaia he knows a lot more than me.
Regards


#24

If it’s not in the installer I didn’t install it. What is a microcode?


#25

same fail here…with the latest install media. at the begin of the week everything was good, no problems at all while and after install. but yesterday i make a new setup and get the same error…

thx for help


#26

https://wiki.archlinux.org/index.php/Microcode

https://bbs.archlinux.org/viewtopic.php?id=230516

rusty725 wrote:

    maxxon wrote:

        I am still getting the error.  Am I supposed to just ignore it?

        Thanks

    try this

    sudo pacman -S intel-ucode
    sudo grub-mkconfig -o /boot/grub/grub.cfg

Saw the same firmware bug message today on my Lenovo, the steps above removed the error. Thanks!

#27

Add me to the list of users encountering this problem. I can edit the /installer/installer file as needed, and I can use pacman to update the intel-ucode, but I cannot execute the command sudo grub-mkconfig -o /boot/grub/grub.cfg. It returns an error about grub-probe not being able to find the “canonical path of airootfs.”

Is that command targeted at systems with Arch or Archlabs already installed? If so, does a similar command for the usb Live version exist?

If not, has anyone come up with a way to install Archlabs to a usb drive? I tried using just the changes to the installer, but that effort failed - it produced the same error about can't open /proc/cmdline: no such file and missing GLIBC_2.28 as well as missing /usr/lib/libmount.so.1, etc., noted above.

edit01: this post about manjaro seems promising;


#28

Hi Oscar, hi Eunosm3,

you need chroot into the new installation before you do the grub-mkconfig. And before you chroot you need to mount the /boot and / somewhere like /mnt/ or /run/media/ of course.

I‘ve done that before, because I wanted to put / on /dev/sda1 and /boot on /dev/sdc and the installer didn‘t offer that option. So I installed archlabs on /dev/sda1 and skipped the boot-partition, didn’t restart after installation was complete, mounted / and /boot inside /, arch-chroot into /mountpoint/, did the grub-mkconfig, exited, unmounted / and /boot, and restarted the system without the livearchlabs. Can‘t reproduce every step right now, but you will find examples und help to this topic inside the archwiki, stackexchange and so forth.

In case you suceed, please let us know, and if you have more time than I have right now, I guess many people would be delighted to get a more detailed description of the process.


#29

Apologies for the long delay to your last response. I’ve been preoccupied with a different project. I think I’ll have time to attempt this again.