ArchLabs Linux

Can't get to BIOS on Acer Laptop

I have been trying to access my bios and I’ve tried everything I could. I believe at this point that my bios are messed up. Below I have my laptop model and what I have done.

LAPTOP MODEL: Acer Swift SF314-54

STEPS TAKEN:

  1. I have tried to boot using the F2 key. Both holding and bashing it. All I get is a black screen with no text.
  2. Bashed and held F10, F11, F12, DEL. All I see is the Acer logo for split second and prompted at the GRUB menu for booting into ArchLabs.
  3. I looked up many problems revolving around this issue, none of which worked.
  4. Powered off the laptop and left ot off for 30 minutes. Nothing new from repeating steps 1 and 2.

PREVIOUS INSTALLATIONS:

I have distro hopped before. Many times, so I don’t know if this is the cause of no longer having a BIOS.
I have NEVER tried to update/change the BIOS.

It should be F2, is your F2 key broken or do you need to use a function key combo to use it?

Please try

systemctl reboot --firmware-setup

My F2 key isn’t broken. I barely use my function keys, but I have also tried using a keyboard and yield no result. I just used the specified command I got the same black screen with no text. I have looked up the mannual of my model laptop.

LINK TO MANUAL: http://content.etilize.com/User-Manual/1041665532.pdf

On page 41, it says, “To activate the BIOS utility, press F2 while the computer logo is being displayed.”

So you get to a black screen and nothing else happens?

Resetting it might help, opening it up and removing the little battery from the motherboard for few seconds then reinsert and try again. If you are using the key and reaching an end state other than normal boot then we can be sure that the bios itself is the issue.

This is firmware level stuff and not something that can happen from installing operating systems.

This was my last resort on the list since I didn’t want to open up the laptop and remove the CMOS battery (I think that’s the name of it). I’ll report back once I have done this.

1 Like

I only ever owned acer laptops and they’re usually pretty easy to get into, there’s also plenty of teardown vids that can help with spots that might not be obvious. Fingers crossed for you, might need to look into flashing if the bios is out of date but that’s a later thing.

After waiting for my iFixIt kit to come, I have finally got back my BIOS. I simply pulled the CMOS battery for a few seconds and made sure that the laptop had no power in it, boot it and waited a few seconds.

Very nice