Canon imageClassMF8580CDW not working: always Device Busy


#21

How did you install the printer driver? If via PKGBUILD you wouldn’t install as root, that is discouraged and im pretty sure it wouldn’t go ahead anyhow.

The only other thing i can suggest is going by that screenshot its showing the driver as generic postscript printer, im pretty sure that is incorrect but i could be wrong. It should be the canon driver in that description.

When i had to get my brother laser jet going i installed the needed drivers, then cups didnt recognize it so i installed below package and upon starting that program the brother printer driver showed up so i followed the settings there and did a test page print out and all was good. That is about all i can suggest leo, otherwise im just guessing and leading you astray.

You may already have this installed?

system-config-printer 1.5.11-4

https://www.archlinux.org/packages/extra/x86_64/system-config-printer/


#22

Well , looks weird, maybe install wath s7l suggests.

system-config-printer 1.5.11-4


#23

Hi s7l. Yes, you are not able to install as root for https://aur.archlinux.org/packages/cndrvcups-common-lb/ via PKGBUILD. It will not let you go ahead but I installed only that piece using sudo. To be honest I don’t think this is the right package with the drivers. If only the debtap conversion worked with the drivers supplied by Canon we would have an adequate test and comparison.
I have already installed system-config-printer. When you configure the printer via CUPS admin http://localhost:631/admin, it will show up there. You are able to see the “completed” jobs there too but nothing spits out of the printer.


#24

Im not sure i understand what you have done, what has worked and what has not?

can you go over step by step what you have done since you tried making a PKGBUILD with deptap, what is the link to the canon .deb printer driver file?

Dont use sudo/root when installing from the AUR or with any self made PKGBUILD, makepkg/pacman uses fakeroot for this, much safer.


#25

Hi s7l,

I followed the instructions for installing CUPS and then activate org.cups.cupsd.service and org.cups.cupsd.socket (https://wiki.archlinux.org/index.php/CUPS#Installation)

Then I followed the instuctions for installing avahi to scan for network printer (https://wiki.archlinux.org/index.php/CUPS#Connection_Interfaces ->
https://wiki.archlinux.org/index.php/Avahi#Hostname_resolution)

Next is the troublesome part - installing the printer drivers which comes in only DEB and RPM packages from the manufacturer Canon.

This is the link to the Canon Linux driver. Autodetected for the Linux 64 bit.2dd
https://www.usa.canon.com/internet/portal/us/home/support/details/printers/color-laser/mf8580cdw/color-imageclass-mf8580cdw

When I first tried debtap on the deb packages I encountered the following error which was posted to AUR. https://aur.archlinux.org/packages/debtap/
Error: You must run at least once “debtap -u” with root privileges (preferably recently), before running this script

sudo debtap -u
==> Synchronizing pkgfile database… :: Updating 5 repos… extra is up to date core is up to date multilib is up to date download complete: archlabs_repo [ 26.0 B 109B/s 1 remaining] error: failed to create archive reader for archlabs_repo: Invalid or incomplete multibyte or wide character download complete: community [ 18.7 MiB 17.1M/s 0 remaining] :: download complete in 1.09s < 18.7 MiB 17.1M/s 2 files > :: waiting for 1 process to finish repacking repos… Synchronization failed. Exiting…

@helix replied:
debtap officially supports only Arch. If you want to use it with an Arch derivative, comment the extra repos of your distro in /etc/pacman.conf, then synchronize debtap, then uncomment those repos.

Following those instructions solved that particular issue and the arch packages were generated. However when I tried to install the newly created Arch package I get the falling error:
sudo pacman -U cndrvcups-common-4.10-1-x86_64.pkg.tar.xz
loading packages… resolving dependencies… warning: cannot resolve “cupsys”, a dependency of “cndrvcups-common” warning: cannot resolve “gs-esp”, a dependency of “cndrvcups-common” :: The following package cannot be upgraded due to unresolvable dependencies: cndrvcups-common

I then follow your excellent suggestion and tried this: (I used yay - which goes in the fakeroot environment)
https://aur.archlinux.org/packages/cndrvcups-common-lb/

Using system-config-printer I get the following:

looking into error log in http://localhost:631/admin/log/error_log
E [14/Mar/2019:13:12:48 -0400] [Client 27] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MF8200C-Series) from localhost.
E [14/Mar/2019:13:12:48 -0400] [CGI] Cannot connect to remote printer ipp://Canon52fc10.local:80/ipp/print (Canon52fc10.local:80)
E [14/Mar/2019:13:12:48 -0400] copy_model: empty PPD file
E [14/Mar/2019:13:12:48 -0400] [Client 19] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MF8200C-Series) from localhost.


#26

Sorry mate im out of ideas. Maybe ask someone who has had experience with packaging up .deb files to use in archlinux. Best of luck with it.


#27

Thanks s7l. Your input and help was greatly appreciated. I’ll keep trying until this printer and scanner problem is solved otherwise this is a nice distro.


#28

Yep, printing s get a beating with the latest linux arch debian etc updates since a little bit, sad.


#29

Would you know how I would be able to get the attention of the Archlab developers on this issue? I’m afraid it’s a bit over my head and my Google Fu has not yielded a path to a solution and it is a bit frustrating not to be about to complete your work without the printer.


#30

Just one more question from me leo, did you try the Canonfc52fc10.local option in system-config-printer ?


#31

Yes I did. I also tried out the various printer configurations using CUPS web interface admin screen http://localhost:631/admin but to no success.