Canon imageClassMF8580CDW not working: always Device Busy


#1

using sane: v1.0.27-2
It can find the network scanner:

scanimage -L

outputs:
device `pixma:MF8200C_192.168.0.14’ is a CANON Canon i-SENSYS MF8200C Series multi-function peripheral
testing it:

scanimage >> /dev/null

always produces the following output:
scanimage: sane_read: Device busy

Need assistance.


#2

Hi Leo, have you consulted the arch wiki?

Has some hints for trouble shooting device busy.

https://wiki.archlinux.org/index.php/Sane#Device_busy


#3

Yes, I followed this arch wiki help and I still have the same problem.


#4

You may need proprietary drivers, there are some in the Aur but not for your model.

There might be some more hints with those drivers in the aur page below.

https://aur.archlinux.org/packages.php?O=0&K=Canon&do_Search=Esegui


#5

Thank you for this url s71.
It’s not on the AUR but I see this driver on the Canon website but it looks to be aimed for DEB based and RPM based distros.
https://www.usa.canon.com/internet/portal/us/home/support/details/printers/color-laser/mf8580cdw?subtab=downloads-drivers
Unfortunately I do not have knowledge or experience to be able to convert DEB packages to AUR packages. Hope there is someone on this site with knowledge on this task to help. I think this could be a workaround.


#6

Have a look at this, its called deptap. I havent used it so cant comment on it, might be helpfull in your use case…


#7

Thank you again s71. I installed debtap but when I tried to run it I get the following error:

Error: You must run at least once "debtap -u" with root privileges (preferably recently), before running this script

when I tried to run debtap -u I get the following error:

sudo debtap -u                                                                                                                                                                                                                 
==> Synchronizing pkgfile database...
:: Updating 5 repos...
  community is up to date
  core is up to date
  extra is up to date
  multilib is up to date
  download complete: archlabs_repo        [    26.0   B   120B/s  0 remaining]
:: download complete in 0.22s             <    26.0   B   120B/s  1 file     >
:: waiting for 1 process to finish repacking repos...
error: failed to create archive reader for archlabs_repo: Invalid or incomplete multibyte or wide character
Synchronization failed. Exiting...

#8

@leo00 as i say i haven’t used it so cant help you im afraid, you should direct any questions to the maintainer of debtap. Looks like it is conflicting with the archlabs_repo. Just be mindful going forward with this, if it is not working and you get no response from the deptap, move on. Maybe the Archlabs developers might be able to help here?

Also debtap is in the AUR

https://aur.archlinux.org/packages/debtap/


#9

Thank you s71. I’ve posted comment on AUR. How do I get the attention of the Archlabs developers on this?


#10

Send a message by the github page as well.

Did you install it via github or Aur?

Have you you tried any other options?

Available options:

-h  --h  -help      --help        Prints help
-u  --u  -update    --update      Update debtap database
-q  --q  -quiet     --quiet       Bypass all questions, except for editing metadata file(s)
-Q  --Q  -Quiet     --Quiet       Bypass all questions (not recommended)
-s  --s  -pseudo    --pseudo      Create a pseudo-64-bit package from a 32-bit .deb package
-w  --w  -wipeout   --wipeout     Wipeout versions from all dependencies, conflicts etc.
-p  --p  -pkgbuild  --pkgbuild    Additionally generate a PKGBUILD file
-P  --P  -Pkgbuild  --Pkgbuild    Generate a PKGBUILD file only
-v  --v  -version   --version     Print version

#11

Try https://aur.archlinux.org/packages/cndrvcups-lb/ or perhaps https://aur.archlinux.org/packages/cndrvcups-lb-bin/


#12

Hi s71. I installed it from AUR not from github. You cannot try the other options until you first complete debtap -u. helix responded to my posting on AUR and was able to identify what the issue was and I was able to proceed with converting the deb package to arch package. There were no errors during the conversion process. However when I tried to install the converted arch package I am getting a dependency warning. I posted that back to AUR to get further assistance. Not sure if it is related back to conversion process.


#13

Thank you Head_on_a_Stick. Unfortunately these look to be imageRunner drivers, not my model.


#14

@leo00

The output on the AUR message/conversion output is pretty self explanatory, its asking you resolve a dependency of cndrvcups-common, which maybe a package in the standard repos or one made for the AUR, i couldnt find one in the Arch repos so AUR is the next best one. Also you should let us know here what you posted in the AUR messages.

Try this AUR package to resolve the dependency …

https://aur.archlinux.org/packages/cndrvcups-common-lb/


#15

Thank you s71. Sorry, bit of a noob in terms of posting. Lack etiquette. I installed https://aur.archlinux.org/packages/cndrvcups-common-lb/ and tried printing a page, printer test pages etc. The print queue shows the print job as complete but nothing is printing out of the printer. Not enough sure what I am lacking at this point.


#16

Have you set cups up?

https://wiki.archlinux.org/index.php/CUPS


#17

Yes, I believe so. Here is a screen shot of the admin screen. It states the print job has completed but nothing spits out of the printer. I’m a bit of a loss at this point in time.


#18

Wonder if you reboot both the pc/lappy & printer, what it s doing, unless it was done already.

Edit: Did you install your printer while being root ! It s what worked for me the last time I installed with cups ( unless it wasn t used to install it)


#19

Thank you for your input altman. Yes, I performed the reboot and check that the services was up and running before I did the print test. I installed the printer and drivers using sudo, not as explicit root. I can do a retry of everything as root and see if that is the problem.


#20

Retry as root produced the same results. It’s something else that is missing.