Cannot update install archlabs packages (pgp is unknown trust)

Hi, I stumbled upon this problem while trying to update my system. Update got nuked by archlabs-polybar and its issues with pgp key.

error: archlabs-polybar: signature from “Nathaniel Maia <natemaia10[at]>” is unknown trust
:: File /var/cache/pacman/pkg/archlabs-polybar-3.4.0-4-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

I deleted archlabs-polybar to perform the system update. But still I cannot install that package back from repos, error is the same. Other archlabs packages seems to have the same problem.
Do you have any ideas how to fix it?

Wonder if it can be related to this thread somehow;

Look at @natemaia s post in there.

1 Like

I’ve updated the keyring, try updating once more with

sudo pacman -Syyu

If it still fails then reinstall our keyring manually

cd ~/Downloads
curl -fSL '' -o archlabs-keyring-2019.10.06-1-x86_64.pkg.tar.xz
sudo pacman -U archlabs-keyring-2019.10.06-1-x86_64.pkg.tar.xz
rm archlabs-keyring-2019.10.06-1-x86_64.pkg.tar.xz
sudo pacman -Syyu

That should solve the verification issues.

1 Like

Guess that it would also be a good idea to clear the cache as well with this command before updating;

sudo pacman -Scc
1 Like

Thanks for the fast response guys!
Manual fix posted by @natemaia worked for me.

1 Like

Glad it worked out @fitter