Cannot run system update, compton dependancy error

Trying to run pacman -Syu results in:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlabs                                        14.4 KiB  19.6 KiB/s 00:01 [------------------------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing picom (10-1) breaks dependency 'compton' required by archlabs-paranoid

Do I just need to reinstall paranoid? Is it necessary? Thanks!

Must have an old install. Try to remove archlabs-paranoid first.

3 Likes

Bingo that worked! Sorry to start a thread for such an obvious solution, but I didn’t want to screw up anything.

No worries.

Was that you with the same question/issue on the ArchLabs reddit page?

1 Like

Nope not me, guess I wasn’t the only one.

1 Like

I had exactly the same error but solved it before checking here, just didn’t want to bother with my old install. It looks like there’s more than one of us :grin:

I tried this but get the message this file is not installed. Any clues where the critter might reside? Thx.

usually one of:

/usr/bin
/usr/local/bin
~/.local/bin

if it’s not installed, you may need to uninstall compton and then install picom.

1 Like