Cannot install i3 ArchLabs version

#1

Heya fellas,
I am currently running ArchLabs with Cinnamon on it but want to try i3 out and heard that the ArchLabs version comes already configured and that’s why I want to try it out, but when I do “sudo pacman -S archlabs-skel-i3-gaps” it gets installed, but I can’t choose it in WM, but when I install normal one everything works fine.
Sadly, the normal one comes in… normal so…
How can I install i3 ArchLabs version?

#2

Using gdm with Cinnamon?

That looks like a /usr/share/xsessions/*.desktop file wasn’t written for the archlabs i3-gaps install. You can create your own.

I don’t recall how i3-gaps installs though - if it uses the ~/.config/i3/config location and just puts it’s own config file in there. May have over written the config when installing i3. So you may need some cleanup there as well.

Welcome to the forum; enjoy the distro.

#3

This isn’t quite accurate, the skel package provided by us includes configs and other minor setup for an i3-gaps install, this doesn’t however include the WM itself, or other applications it might rely on. Hence the name ‘skel’, it’s just a skeleton configuration package.

It also does not make the configs accessible to an existing user, the *-skel pacakges all get installed to /etc/skel which in turn is copied to /home/USER when creating a new user with useradd -m.

As an existing user it would be your job to copy the needed configs to your home directory using something like:

cp -rf /etc/skel/.config/i3 ~/.config/

The i3 setup also relies on a number of other packages to have a usable session, normally done by the installer, you’ll have to install them in this case

pacman -S i3-gaps i3status perl-anyevent-i3 archlabs-skel-i3-gaps rofi archlabs-polybar archlabs-networkmanager-dmenu xdg-user-dirs nitrogen polkit-gnome volumeicon xclip exo xdotool compton wmctrl gnome-keyring dunst feh gsimplecal xfce4-power-manager xfce4-settings laptop-detect arandr --needed

Copy the polybar configs so you have a bar when logging in

cp -rf /etc/skel/.config/polybar ~/.config/

You may also need to grab the default /etc/skel/.xprofile as it contains some startup commands for window managers that would’ve been removed if you only chose a DE during install.

cp -rf /etc/skel/.xprofile ~/.xprofile

Once you have all this done, you should be able to choose i3-gaps at the login screen and the session should be fairly usable, please let me know if you run into any issues as I’m sure there are things missing.

5 Likes
#4

Hello there once again,
Thank you a lot for your reply, it helped me fix the problem, but there’s another one.
At the top bar, I get errors saying “/bin/sh: updates.sh: command not found” and “/bin/sh: check-network: command not found”, and don’t know which packages to install to make them work, got any ideas?

#5

Those scripts should be included in /etc/skel/bin, you might find them in ~/bin/ but it may not be on the PATH, so polybar can’t find them

ls ~/bin
echo $PATH

Use find to find and copy them to somewhere on your PATH like /usr/bin in one command

sudo find / -name 'updates.sh' -exec cp -fv '{}' /usr/bin/ \;
sudo find / -name 'check-network' -exec cp -fv '{}' /usr/bin/ \;

If they can’t be found then you can get the most recent versions here but you’ll need to change the names or edit the polybar config to look for those files, then copy them to somewhere on your PATH.