Cannot activate redshift with the icon in polybar


#1

Hello, first of all. I am new here, have AL with just openbox installed for about a week now and tried some things out. Btw, I really love it. One of the things I tried to use was the redshift indicator for polybar. However, I am not able to start redshift with the indicator in the top bar, I need to start redshift manually (for example with rofr or zsh).
When it is running, I can stop it with the indicator, though. Don’t ask why.
I looked up how this thing works. So the command which should toggle redshift was toggle.sh -r -t. I then executed that command manually and redshift did it’s job. Executing that same command in another shell then killed redshift, as it should. I then debugged it and let it write the arguments into a file whenever it is executed, which did bring the results that polybar does actually execute toggle.sh -r -t and in theory redshift should start therefore. For some reason, it did not. Do you have any ideas? Thank you for your help in advance.