Can not update after new install

I have earlier reported on a success story with MacBook Pro 8,1 (late 2011) but last nigth “my old friend” died! Today I have done a new install on a MBP 13 retina (late 2014) and I am having trouble updating. I get the message “archlabs-user-skel : /etc/skel/.vimrc already exists in filesystem” and then update stops.
Remove /etc/skel/.vimrc?

womp

I once used option 16 of pacli and solved, then option 2.
But I know that every case is a case…

Hi it happened to me too; i wasn’t sure if I could make more damage removing the existing file, so I renamed it and proceed with the update .
It was successful and I tested the system, didn’t find any trouble so i deleted the one i renamed and everything was fine since.
I hope it works for you, please let me know.

Looks like you can go straight with:
rm /etc/skel/.vimrc and you could also, next time you update, need to run rm /usr/lib/libmozjs-52.so.0.
I experienced each issue in two different update sessions.

Apologies for the issue with /etc/skel/.vimrc, its now just part of our user package.

The /usr/lib/libmozjs-52.so.0 wasn’t me however, must be some other changes upstream to som javascript libraries

Cheers

I do not think this centers package with / etc / skel
but maybe I’m wrong.
Cheers

[don@don-pc ~]$ sudo pacman -Qi js52
Nome                      : js52
Versione                  : 52.7.3-2
Descrizione               : JavaScript interpreter and libraries - Version 52
Architettura              : x86_64
URL                       : https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey
Licenze                   : MPL
Gruppi                    : Nessuno
Fornisce                  : Nessuno
Dipenda da                : gcc-libs  readline  zlib  sh
Dipendenze opzionali      : Nessuno
Richiesto da              : polkit
Opzionale per             : Nessuno
Conflitti con             : Nessuno
Sostituisce               : Nessuno
Spazio richiesto          : 46,53 MiB
Pacchettizzatore          : Jan Alexander Steffens (heftig)
                            <jan.steffens@gmail.com>
Data di creazione         : ven 04 mag 2018 17:13:32 CEST
Data di installazione     : ven 04 mag 2018 19:31:36 CEST
Motivo dell'installazione : Installato come dipendenza di un altro pacchetto
Script di install         : No
Convalidato da            : Firma
[don@don-pc ~]$  pactree js52
js52
├─gcc-libs
│ └─glibc
│   ├─linux-api-headers
│   ├─tzdata
│   └─filesystem
│     └─iana-etc
├─readline
│ ├─glibc
│ ├─ncurses
│ │ ├─glibc
│ │ └─gcc-libs
│ └─ncurses provides libncursesw.so
├─zlib
│ └─glibc
└─bash provides sh
  ├─readline
  ├─glibc
  └─ncurses
[don@don-pc ~]$

Hello again!

I am overwhelmed over the response here! Really great forum!!
I did remove /etc/skel/.vimrc and update went as usual after that. Now I have wifi working also. I am doing this on my “work-book” (because my old friend died). I am using a 64GB usb-stick and so far I only have one little problem. I cannot make screenresolution stick between reboots. “My old friend” was very easy to install to and now this is the first time on retina. I will read up on mbp-retina and see if there is a good solution to this. Unless someone here has a hint?

Thanks for support!!

womp

Yes! It seems like I have worked out the resolution problem! I used xrandr and xfce controlcenter and managed to make a save to configuration!

womp