Bug linux-zen

Hi,
i updated linuz-zen and the system does not restart, says it does not find the uiid, and starts in the emergency shell.
Restarting with the second kernel, I downgrade linux-zen and the system starts again without problems, it happens to you too and then it’s a bug, or it’s just my problem.

It s safe to have a backup kernel, guess it s the update s at fault here on your case @ector

Edit: they might issue another patch soon to fixe this, have a look at their forum if they have one, been years that I haven t had any Zen kernel installed on my lappies.

Did you install the zen headers?

Zen has worked perfectly me for a long time, well forever really.

The headers are only needed if ector wants to compile any custom kernel modules, the package should not be needed for booting.

@ector, do you have /boot on a separate partition and was it correctly mounted during the kernel upgrade?

There is a newer kernel version in [testing], you could try that:

https://www.archlinux.org/packages/testing/x86_64/linux-zen/download/

For now, thanks for the help, I have also created a help on github linux-zen.
the maintainer sent me here:

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux-zen&id=b55617296b6ee842fd5962525f3feeccc7752e0a

even if I do not understand much it speaks of static usb.
the distro fact is on external usb ssd samsung, I do not understand why during the upgrade you can not find the / root.

I installed the testing but same thing and same error.
Yes, the / boot is mounted correctly.

blkid

[don@don-pc ~]$ sudo blkid
[sudo] password di don: 
/dev/sdb1: LABEL="WINRE" UUID="6C601F52601F227E" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="1f6fcd24-f066-43c5-a2d5-fb28b4def1d3"
/dev/sdb2: UUID="F46A-0B46" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="5a32f4df-a9fb-4e38-8b6a-29b67cf061a9"
/dev/sdb3: PARTLABEL="Microsoft reserved partition" PARTUUID="c010b313-736a-4cf5-86e0-ac6b7afeaa76"
/dev/sdb4: LABEL="Windows 8.1" UUID="7A646DD0646D9025" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="f26495e6-b252-4336-b445-8cc81dc2d3f0"
/dev/sdb5: LABEL="Windows10" UUID="5880C14C80C130F4" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ac09419f-b641-47df-8568-8837d4c831d9"
/dev/sdb6: UUID="7EC86182C8613A13" TYPE="ntfs" PARTUUID="d7f3f4fc-6d3f-4457-b633-6a6049bfb895"
/dev/sdb7: UUID="8CF45F2DF45F18B2" TYPE="ntfs" PARTUUID="b581ff73-0d9f-46d2-9aa7-e8a31b1a70d7"
/dev/sdb8: UUID="E81033BF10339412" TYPE="ntfs" PARTUUID="9d01b65e-3ff1-4ffd-855e-d746d031e677"
/dev/sdb9: LABEL="RECOVERY" UUID="00761CEF761CE6E6" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="17c4d895-22de-4ff3-bf48-33dac479d6e6"
/dev/sda1: UUID="F0F4-D79B" TYPE="vfat" PARTUUID="d75c2c06-8dd5-483b-aa0a-836c97a93f12"
/dev/sda2: LABEL="arch64-grub-mate" UUID="2a67a883-dacf-4837-ac69-f59b6ed0d49b" TYPE="ext4" PARTUUID="e4934a63-2725-44b5-9e4f-6d48c77c8fe7"
/dev/sda3: UUID="9AC7-6A17" TYPE="vfat" PARTUUID="b778ec42-945c-4326-8d10-c5341f6a185d"
/dev/sda4: LABEL="xfce4-journal" UUID="81d5807b-de09-4be6-9759-56fb595f954e" TYPE="ext4" PARTLABEL="uefi-xfce4" PARTUUID="0a5ad181-36f4-43f1-bbcd-a7f149c6dad2"
/dev/sda5: UUID="336C-E9C6" TYPE="vfat" PARTUUID="ea08dc57-e9af-4175-a33b-8a9f4beffa68"
/dev/sda6: LABEL="arch64-efi-xfce4" UUID="a16dfbca-26cd-43fc-80e8-a5776510b24e" TYPE="ext4" PARTUUID="eaa41dea-118b-4fae-acb8-2f7a2a254d69"
/dev/sda7: UUID="2FC8-5684" TYPE="vfat" PARTUUID="45e1fcb1-d0be-42b2-8c46-e1cf9f417e4f"
/dev/sda8: LABEL="Archlabs" UUID="91a7796a-ed61-4963-9026-4456b3389029" TYPE="ext4" PARTUUID="4692c57d-b10b-4e41-8e08-4522de1a392e"
/dev/sda9: LABEL="Ntfs-media" UUID="0961B5D740DB0491" TYPE="ntfs" PTTYPE="dos" PARTUUID="840dbf73-e58b-4f6c-9848-b41aec10266f"
/dev/sda10: UUID="CBA0-2BBE" TYPE="vfat" PARTUUID="7e898a08-4f85-4e89-a4f0-c11fe317328a"
/dev/sda11: LABEL="Archlabs-minimo" UUID="c9c94dfd-8f6b-4520-994c-a15363a45a84" TYPE="ext4" PARTUUID="0acfeca7-0aaa-4c1f-b9e6-b094edae44ae"
/dev/sdc: UUID="3874-07D4" TYPE="vfat"
[don@don-pc ~]$ 

mount

[don@don-pc ~]$ mount
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
dev on /dev type devtmpfs (rw,nosuid,relatime,size=4026660k,nr_inodes=1006665,mode=755)
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda8 on / type ext4 (rw,noatime,stripe=8191,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=30,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
tmpfs on /tmp type tmpfs (rw,noatime)
/dev/sda7 on /boot/efi type vfat (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=806640k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/sdc on /run/media/don/3874-07D4 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)
[don@don-pc ~]$ 

i found this,but I do not understand if they have solved or not.
https://bugs.archlinux.org/task/60272

Thinking about it, wonder if it s related to this thread somehow:

Or it might have nothing to do with it at all.

1 Like

Thank @altman
To date it still does not work, the last upgrade and on all the distro I installed.
Boh
Regards

1 Like

Gee that sux, hope you ll get it sorted soon @ector !

1 Like

How did you check this?

Have you looked at the timestamps on the files in /boot to check when they were changed?

The error message can happen when the kernel version & initramfs are different and so the correct kernel modules to mount the partition cannot be found.

1 Like

If you tell me how I must do, maybe the place.
But if I downgrade the old version of kernl linux-zen, everything works
Thank.

The linux-zen maintainer answered me this way.
@heftig looks like this is related to the config changes and static USB modules.
Until that bug is fixed you can boot with the fallback initrd.
Does anyone know what this means?

Edit
and sent me back to this page, which I had already posted if I’m not mistaken.
Bug confirmed
https://bugs.archlinux.org/task/60272

1 Like

Guess he wants you to do the same that you did in this thread with the older kernel that works concerning the bug.

Just wait & see if they fix the bug in his forum or whatever that you got the email from @ector

1 Like

for the moment I solved this way.
Added in etc / mkinitcpio.conf modules
usb_storage uas
mkinitcpio, and started in fallback
now the last linux-zen kernel works

Edit
start also without fallback

1 Like

Glad that you fixed your issues in there @ector