Bspwm WM does not utilize full screen of computer


#1

Installed bspwm flavor of ArchLabs but when logged on, the WM does not utilize full screen of the computer. Any assistance is appreciated.


#2

You’ll get more/better responses if you specify clearly what exactly is going on and what you would like/expect instead, screenshots, pictures, and basic system info regarding the issue also help a great deal.

Have you used tiling window managers before? More specifically bsp?


#3

Please post the content of ~/.config/bspwm/bspwmrc


#4

My screen shot. The full window does not take up the full computer screen real estate when I log in. I’ve used awesome in the past but different distro. I wanted to give this distro a try with a different tiling manager, with bspwm in mind. Tried dwm but found it too bare at the start to be productive and did not have the time to go through the patches and merging. A future project though :slight_smile:


#5

~/.config/bspwm/bspwmrc (just straight from the refresh install).

#!/bin/sh

# set root pointer
xsetroot -cursor_name left_ptr

# key bindings
sxhkd &

# wallpaper
nitrogen --restore &

# launch compton
al-compositor --start &

# xfce settings
xfsettingsd &

# panel
al-polybar-session &

# Set some bsp specific stuff
bspc monitor -d I II III IV V VI VII VIII IX X

bspc config border_width 3
bspc config window_gap 12
bspc config top_padding 18
bspc config right_padding 0
bspc config bottom_padding 0
bspc config left_padding 0

bspc config split_ratio 0.54
bspc config borderless_monocle false
bspc config gapless_monocle true
bspc config paddingless_monocle true

bspc config pointer_modifier mod1
bspc config click_to_focus true
bspc config pointer_action1 move
bspc config pointer_action2 resize_side
bspc config pointer_action3 resize_corner

bspc rule -a thunar desktop='^1' state=floating follow=on
bspc rule -a firefox desktop='^3'

#6

Please enclose the file content with triple backticks to enable a code block, thanks!

Can you move (or resize) the windows into the blank space?

What is the output of

bspc wm -d | jq '.monitors[].rectangle'

Does this fix things:

bspc monitor -g 1920x1200

Reference: https://github.com/baskerville/bspwm/issues/893


#7

Thanks Head_on_a_Stick.
No I cannot move (or resize) the windows into the blank space.
Output of

bspc wm -d | jq '.monitors[].rectangle'
{
  "x": 0,
  "y": 0,
  "width": 1920,
  "height": 1200
}
{
  "x": 0,
  "y": 0,
  "width": 1366,
  "height": 768
}

This.

bspc monitor -g 1920x1200

in this form:

bspc monitor -g 1920x1200+0+0

works.
Much obliged!


#8

Please mark the post that solved your issue so others having the same issue know there is a solution here.


#9

This worked when entering on the command line on the terminal. I also added the line into ~/.config/bspwm/bspwmrc but when I quit the system and logged back in and launch a new terminal I get the same problem as before. I don’t want to have to enter the command each time I start linux. So I spoke too soon. Not completely solved.


#10

Does adding this to ~/.config/bspwm/bspwmrc fix things without using the bspc monitor -g hack?

for side in top right bottom left; do bspc config ${side}_monocle_padding -10; done

See https://github.com/baskerville/bspwm/issues/925


#11

No. Adding it to ~/.config/bspwm/bspwmrc did not fix the issue.


#12

OK, I think it may be best to take this upstream and open an issue on Bastien’s github page.

Reference issue #893 or attempt to re-open that issue if you can, thanks!


#13

Found something else after some experimentation. I originally did this:

# Set some bsp specific stuff
bspc monitor -g 1920x1200+0+0
bspc monitor -d I II III IV V VI VII VIII IX X

and this did not seem to work. I remove:

bspc monitor -g 1920x1200+0+0

and put it at the end of ~/.config/bspwm/bspwmrc and that did solved the original issue. Thanks Head_on_a_Stick. This leads into another problem discovered, the workspaces I II III IV V VI VII VIII IX X are not showing up on the left hand side of the top bar.