Bspwm autostart panel and more

Good Evening! I am sorry to disturb again but …

I am trying to set up BSPWM:

  1. Can not autostart any panel or bar! Want polybar but have tested tint2 and yabar too with same result.
    I can start all panels in terminal but to start polybar I have to:
polybar -c .config/polybar/config bspwm-bar &

If I

polybar -c /.config/polybar/config/ bspwm-bar &

file or folder can not be found!

(I find this strange and it has never happened before. Something with bash configuration?)

After starting panel manually I have no ws-indicators and can not change ws. Superkey does not seem to work for BSPWM only for sxhkd.

You may think itś crazy to set up i3-gaps, awesome and BSPWM on the same system but I have an idea of finding out which fits me the best. They are all really great wm:s.

Here is my bspwmrc:

#!/bin/sh

# set root pointer
xsetroot -cursor_name left_ptr

# key bindings
# shared common keybindings (applications)
sxhkd &
#flameshot &
#tint2 &
#$HOME/.config/polybar/launch.sh
polybar -c .config/polybar/config bspwm-bar &
#yabar ~/.config/yabar/yabar.conf &
# Dunst #####################
dunst -conf  ~/.config/dunst/dunstrc &


# Set some bsp specific stuff
bspc LVDS-1 -d I II III IV V VI VII VIII IX X

bspc config window_gap  8
bspc config border_width 2

bspc config split_ratio 0.50
bspc config borderless_monocle true
bspc config gapless_monocle true

bspc config automatic_scheme alternate
bspc config initial_polarity second_child

bspc config normal_border_color	"#4c566a"
bspc config active_border_color	"#1e1e1e"
bspc config focused_border_color "#327bd1"
bspc config presel_feedback_color	"#327bd1"
bspc config urgent_border_color "#dd2727"



bspc config top_padding          20
bspc config bottom_padding       8
bspc config left_padding         0
bspc config right_padding 		 0

#Focus on pointer
bspc config focus_follows_pointer true
bspc config pointer_follows_focus true

bspc config pointer_modifier mod1
bspc config pointer_action1 move
bspc config pointer_action2 resize_side
bspc config pointer_action3 resize_corner

###---Rules---###
#bspc rule -a mpv state=fullscreen
#bspc rule -a Zathura state=tiled
#bspc rule -a Screenkey manage=off
bspc rule -a Pamac-manager state=floating

bspc rule --add pavucontrol                 state=floating
bspc rule --add Pcmanfm                     state=floating
bspc rule --add Pamac-manager		    state=floating
#Scratch
#bspc rule -a dropdown sticky=on state=floating hidden=on
#termite --class dropdown -e "bash -i" &
st -c scratchterm &
bspc rule -a scratchterm sticky=on state=floating hidden=on

bspc rule -a geany desktop='^0' follow=on
bspc rule -a firefox desktop='^1' follow=on
#bspc rule -a Firefox desktop='^3' follow=on
bspc rule -a thunar desktop='^2' follow=on
bspc rule -a simplenote desktop='^3'follow=on
bspc rule -a android-messages-desktop desktop='^3'follow=on

Hope there is someone recognizing this!

womp

Check again.

1 Like

I think @womp is providing a valuable service configuring many WM’s and asking questions here. He kinda deserves his own category “womp’s Window Manager Adventures”. I don’t mean that in a sarcastic way either, there is a lot of valuable information in his threads that can help everyone who browses here looking for information.

1 Like

Very nicely put!

Thanks!!

womp

1 Like
polybar -c /.config/polybar/config/ bspwm-bar &  
error: Failed to open config file /.config/polybar/config: No such file or directory

polybar -c /.config/polybar/config bspwm-bar &
error: Failed to open config file /.config/polybar/config: No such file or directory

cd /.config
error: No such file or direcory

cd .config

works

Is there something wrong with my bash configuration?

womp

It’s looking for your config file in the root directory ( / ) not /home/womp/.config (or ~/.config if you prefer)

In your bspwmrc try:

polybar bspwm-bar &

by default, polybar will search for ~/.config/polybar/config first, so as long as bspwm-bar in defined/configured in ~/.config/polybar/config you do not need to use the full path. If you’re using a different config file or location, then you need polybar -c (path-to-config-file)

polybar wiki - scroll down a bit to window manager startup

1 Like

My god how stupid am I?

Sorry! I get sometimes a bit too eager!

womp

Thanks for answering!
polybar bspwm-bar &
works from terminal but without indicators for workspaces and superkey/lin-key is dead. I have only one workspace.
I have also tried the launch.sh (from polybar-home and I edited the script bspwm-bar instead of example) script and that works from terminal but will not autostart bspwm and superkey/lin-key still dead.

Still not possible to autostart panel.

With or without panel the super-key/lin-key is dead for bspwm-tasks.

womp

What was the error message? Polybar will usually give a reason why a module failed.

Are you trying to use icons as desktop indicators? An appropriate font will need to be installed and called in the polybar configuration.

Make sure your bspwm module is correct.

1 Like

What do you mean by this? If the key isn’t launching applications like you want, that is more likely a problem with sxhkd configuration since it handles the key bindings. You may be calling the key wrong. Also, if you’re using ksuperkey and loading it from your ~/.xprofile it can mess up sxhkd.

Actually no error-messages only a warning about a setting becoming obsolete.
I am trying to use AL-polybar-config (config, master.config and modules.config). I have checked, edited and tested alot and I can not get workspeces to show in polybar!
Can not change workspaces either. Only one workspace.
Can a missing font do all that damage?

womp

I have been reading alot and one thing came up. Permissions! I fixed that and now super-key/lin-key works partially. (still can’t change workspace.) Change of permissions made it possible to autostart polybar though!
Here is how it locks now:

womp

1 Like
bspc rule -a geany desktop='^0' follow=on

This cannot work, bspwm can’t find desktop 0…
Maybe you’re confused with “ws-icon-0 = 1;” in your bspwm polybar module. Wiki

3 Likes

Is LVDS-1 the correct designation for the monitor?

Try:

bspc monitor -d I II III IV V VI VII VIII IX X

in a terminal or in your bspwmrc.

1 Like

@PackRat and @archus !!

These 2 changes made alot of difference!!
Now I have workspaces and I can move between them!!

Thank you so much!!

(scratchterminal stopped working though. I will try to figure out).

There should be an option for giving the “solution” to more than one person or answer here!! @archus and @PackRat are both part of the “solution”!!

womp