Broke My Internet Connection - Can't Find a Fix

Earlier today I was messing around in SDDM, trying to change theming and the backgroun wallpaper. I couldn’t get what I wanted so I set everything back to default (I thought) and rebooted - everything appeared to boot as normal. BUT no internet connection! What? The ISP seems to be working fine because I can connect to the internet with my phone via the wifi router.

What could I have messed up? How to diagnose? I have spent an hour or so with ArchWiki with no success.

I’m unsure how to answer this but I would start by reviewing your settings for NetworkManager (assumed you are using that).

What is “everything”? :grinning:

1 Like

… and come to think of it, if all you were doing was theming SDDM, I don’t suspect that would have anything to do with your internet connection. Like chroot mentioned, I think you need to be more specific about what is everything.

Do you dual boot? By chance were you into Windows OS before this problem started?
If so try the following.
disable fast startup
disable hibernation completely

1 Like

My apologies - frustrated and flustered after this afternoon. “Everything” was not much, just this:

  • I read in the sddm description that the default theme is maya and so the "Current = " line in the Theme section of sddm.config is left blank
  • Using sudo micro I went into /usr/share/sddm/sddm.config and entered a different theme name there so that it read Current= dialog (the name of a different theme in the same folder as the other available themres)
  • I saved the edit, exited micro and rebooted. No change to sddm AND no internet
    -I went back into /usr/share/sddm/sddm.config and reverted to Current= [left blank]
  • rebooted and still no internet.

I’m hard pressed to think anything with SDDM messes with the internet.
Did you happen run updates before all this?

No worries. We can figure it out.

You use wired or wireless connection? I assume it’s networkmanager. Right?

1 Like

I ran updates when I first booted this morning and I have had no internet issues until this.

Like chroot just mentioned, I would review your NetworkManager settings

It’s wired. What do you suggest I run to check NetworkManager?

Post,

$lspci -v

and

$ip a

How am I going to do that without a connection ?

You have access to console?

Make sure “ip a” displays your wired connection.

I have a terminal and I am root if that’s what you mean?

Is it possible that something was broken in this morning’s upgrade that I installed? I did not attempt a reboot any time before this issue started.

type “ip a” from cmd line. What do you see?

1 Like

It’s possible but you need to verify other things before jumping to a conclusion. If you like, you could try to downgrade the packages that you just updated earlier today.

It is possible but probably unlikely that a driver for your network device may have been blacklisted. That does not happen often but it does.

ip a does not appear to be showing a connection. There are 4 numbered groups of information