Boot to emergency mode

After yesterdays update, reboot goes to emergency mode. Not experienced enough to know what this means, or the cause. Using the backup boot option seems to work and appears to use 4.17.5 kernel without the emergency mode business. Running on amd64. Booting from emergency mode also seems to bring up the same kernel and appears to work once it gets booted. Several reboots seem to all end up in emergency mode

Make sure that all of your partitions are mounted correctly — pay particular attention to the /boot partition (if you have one) — and then update the initramfs:

mkinitcpio -p linux

A reboot should result in a working system again (hopefully).

We need to find out why your system broke so please post the output of

findmnt
parted --list
pacman -Qi linux
uname -a

Thanks!

It appears that it may be fixed. I had an external disk mounted when I originally shut down. That disk required my password to mount. I just now mounted it and unmounted it, then rebooted, and boot proceeded normally. When the boots failed where was a message about “dependency failure /mnt/‘external disk name’”. I had never done a reboot with that disk mounted before. I foolishly associated the dependency failure with something in the latest update. Oh well, I learned something new. I feel better now because I really like Arch Labs after a few months of use. Up to date, stable and light weight with a responsive, helpful forum. What more could anyone ask. Thanks for the quick response.

@Head_on_a_Stick, do you believe the output you asked for would still be beneficial to others with similar issues?

@michael, happy to hear you seemed to have worked it out :slight_smile: If Head_on_a_Stick believes it may still be either important to you or others, would you mind still posting that output? Doing so may help another user find the solution too.

If he doesn’t, just ignore me :stuck_out_tongue:

Thanks

1 Like

Well, my supposition was that the initramfs did not match the kernel image, this was based on the OP’s observation that “the backup boot option” worked — I’m not actually familiar with ArchLabs’ boot options (sorry!) but I was guessing that boots the fallback initramfs image; I could be wrong about that though (and was here).

Having a /boot partition incorrectly mounted during a kernel upgrade can cause similar issues, hence the check on the installed vs. running kernel versions.

@OP: if this happens again you can use journalctl to diagnose the problem:

2 Likes

^This is what I thought as well (actually, I’m guilty of). @michael, if your’re down with this… Please mark this as solved. Thanks @Head_on_a_Stick :slight_smile:

Hi,
I have the same issue since yesterday. I have no idea from where it can come from since I didn’t plug any peripheral since a while. On boot, it says that I have an issue with my data partition, which is on a second internal HDD, but I have no issue using it. I did run

mkinitcpio -p linux

but it didn’t solve my issue. Any help appreciated !
edit : I can access my computer as usual if I type (as suggested) ctrl + d. But it doesn’t explain why it broke somehow.



edit2 : journalctl gives me this :

Edit /etc/fstab and add nofail to the options in the line for /mnt/Data

This partially did the trick.
I now come to lightdm, just like before, but during the boot process things have changed. It goes too fast for me to read them but it still differs with what i’m used to.
Anyway, thanks ! That will be sufficient for now ^^

This will list the messages for the current boot:

journalctl -b

But please don’t post a screenshot of the output, if you must share the contents then upload them to http://paste.debian.net/ and post a link here (or use the markdown features to post them directly).

Not sure what happened but it isn’t Archlabs specific. I came home last night to a failed boot, running mkinitcpio fixed my issue, it was also due to an extra partition failing to mount (not boot or anything in particular, just a storage drive).

@gazeka74

Wonder if you changed the Grub Time out without knowing it while tweaking your parameters.

@Head_on_a_Stick I will do that probably this evening, if I can manage to find the time. After all, we are almost at french national day and there are already some activities planed tonight :smiley:

@altman I don’t think I ever touched that. But I did change some of the bios settings ( long story short, didn’t manage to install W10 uefi’s way. Now I can go on it but I do have to access it through the bios rather than grub. But ain’t really an issue).

@natemaia It’s funny that for some reason some of us have similar issue at the same time. But mine might be not related tho I agree on that.

edit : just found this on arch forum
https://bbs.archlinux.org/viewtopic.php?pid=1796931#p1796931
I’ll test this asap

@gazeka74

Ok cool, thought that you might ve play in the grubs settings, we never know.