Boot stuck on lightDM

hi all, I did something ( god knows what ) and my boot stuck on on when lightdm try to start … .

I believe its related to gpu drivers

Any pointers will be appreciated as I cant be asked to reinstall Archlabs again :slight_smile:

PS i know I don’t give much info … please ask me … cause i don’t know what i am looking for .

What actually happens when you try to boot? What do you see? Can you switch to a console screen with <ctrl>+<alt>+F3?

If not, select the ArchLabs boot menu entry then press “e” and add this to the end of line that starts with “linux”:

systemd.unit=multi-user.target

Then use a pastebin client to generate a link to your LightDM logs.

yeah i can go on one of the consoles
I think it happens after i start playing with nvidia-modprobe command

Does startx work from a console screen? If not then the X.Org log would probably be useful as well.

command not found startx

[  1794.038] 
X.Org X Server 1.20.6
X Protocol Version 11, Revision 0
[  1794.038] Build Operating System: Linux Arch Linux
[  1794.038] Current Operating System: Linux Dell 5.4.7-zen1-1-zen #1 ZEN SMP PREEMPT Tue, 31 Dec 2019 17:20:22 +0000 x86_64
[  1794.038] Kernel command line: \\vmlinuz-linux-zen pti=on page_alloc.shuffle=1 \\vmlinuz-linux-hardened root=/dev/mapper/cryptroot  cryptdevice=UUID=20cfd6ac-7dc7-4b7c-afc5-4a8d7ed9659b:cryptroot rw add_efi_memmap i915.enable_psr=0 mem_sleep_default=deep initrd=\initramfs-linux-zen.img
[  1794.038] Build Date: 19 December 2019  06:52:37PM
[  1794.038]  
[  1794.038] Current version of pixman: 0.38.4
[  1794.038] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  1794.038] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1794.038] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan  3 14:08:59 2020
[  1794.038] (==) Using config file: "/etc/X11/xorg.conf"
[  1794.038] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  1794.038] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1794.038] (==) ServerLayout "Layout0"
[  1794.038] (**) |-->Screen "Screen0" (0)
[  1794.038] (**) |   |-->Monitor "Monitor0"
[  1794.038] (**) |   |-->Device "Device0"
[  1794.038] (**) |   |-->GPUDevice "Device0"
[  1794.038] (**) |-->Input Device "Keyboard0"
[  1794.038] (**) |-->Input Device "Mouse0"
[  1794.038] (==) Automatically adding devices
[  1794.038] (==) Automatically enabling devices
[  1794.038] (==) Automatically adding GPU devices
[  1794.038] (==) Automatically binding GPU devices
[  1794.038] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  1794.038] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF,
	/usr/share/fonts/Type1,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/75dpi
[  1794.038] (==) ModulePath set to "/usr/lib/xorg/modules"
[  1794.038] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1794.038] (WW) Disabling Keyboard0
[  1794.038] (WW) Disabling Mouse0
[  1794.038] (II) Module ABI versions:
[  1794.038] 	X.Org ANSI C Emulation: 0.4
[  1794.038] 	X.Org Video Driver: 24.0
[  1794.038] 	X.Org XInput driver : 24.1
[  1794.038] 	X.Org Server Extension : 10.0
[  1794.039] (++) using VT number 7

[  1794.039] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  1794.039] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1794.188] (--) PCI:*(0@0:2:0) 8086:3e9b:1028:0905 rev 2, Mem @ 0xeb000000/16777216, 0x80000000/268435456, I/O @ 0x00004000/64, BIOS @ 0x????????/131072
[  1794.188] (--) PCI: (1@0:0:0) 10de:1f91:1028:0905 rev 161, Mem @ 0xec000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/524288
[  1794.189] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  1794.189] (II) LoadModule: "glx"
[  1794.189] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  1794.192] (II) Module glx: vendor="X.Org Foundation"
[  1794.192] 	compiled for 1.20.6, module version = 1.0.0
[  1794.192] 	ABI class: X.Org Server Extension, version 10.0
[  1794.192] (II) LoadModule: "nvidia"
[  1794.192] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  1794.193] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1794.193] 	compiled for 1.6.99.901, module version = 1.0.0
[  1794.193] 	Module class: X.Org Video Driver
[  1794.193] (II) NVIDIA dlloader X Driver  440.44  Sun Dec  8 03:38:31 UTC 2019
[  1794.193] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1794.193] (EE) No devices detected.
[  1794.193] (EE) 
Fatal server error:
[  1794.193] (EE) no screens found(EE) 
[  1794.193] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[  1794.193] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1794.194] (EE) 
[  1794.244] (EE) Server terminated with error (1). Closing log file.

Well that’s not good :confused:

Do you have the xorg-xinit package installed?

pacman -Q xorg-xinit

not found

In my /etc/X11/xorg.conf

Is trying to use Nvidia :confused:

Can you install it? Try the metapackage:

pacman -Syu xorg

I don’t think you need an xorg.conf for the NVIDIA proprietary drivers any more.

right now when i run startx it comes up with error no screens found ( try to reboot it as well and i got stuck on lightdm again )

We need to see the log really but check if you have the drivers:

lspci -k | grep -iA2 'vga\|3d\|display'

startx



X.Org X Server 1.20.6
X Protocol Version 11, Revision 0
Build Operating System: Linux Arch Linux
Current Operating System: Linux Dell 5.4.7-zen1-1-zen #1 ZEN SMP PREEMPT Tue, 31 Dec 2019 17:20:22 +0000 x86_64
Kernel command line: \\vmlinuz-linux-zen pti=on page_alloc.shuffle=1 \\vmlinuz-linux-hardened root=/dev/mapper/cryptroot  cryptdevice=UUID=20cfd6ac-7dc7-4b7c-afc5-4a8d7ed9659b:cryptroot rw add_efi_memmap i915.enable_psr=0 mem_sleep_default=deep initrd=\initramfs-linux-zen.img
Build Date: 19 December 2019  06:52:37PM
 
Current version of pixman: 0.38.4
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan  3 14:39:55 2020
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) 
Fatal server error:
(EE) no screens found(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

lspci -k | grep -iA2 ‘vga|3d|display’

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile) (rev 02)
	DeviceName:  Onboard IGD
	Subsystem: Dell UHD Graphics 630 (Mobile)
--
01:00.0 3D controller: NVIDIA Corporation Device 1f91 (rev a1)
	Subsystem: Hewlett-Packard Company Device 8601
	Kernel modules: nouveau
--
3d:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981/PM983
	Subsystem: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981/PM983
	Kernel driver in use: nvme

btw, thanks for the help!

and the solution is

somehow messing with nvidia-modprob it changed the /etc/X11/xorg.conf to use the nvidia

then the xorg was trying to start with the nvidia ( not sue why it failed )

i changed the xorg.conf to be

Section "Device"
  Identifier    "Intel Graphics"
  Driver        "intel"
  BusID         "PCI:00:02.2"
EndSection

obv, i didnt know what i was doing by running nvidia-modprob ( noob corner )

now if anyone has any opinion on this mess, i would appreciate the input !

but for now it works, and im gonna backup dd my drive :stuck_out_tongue:

You appear to have an Optimus device: https://wiki.archlinux.org/index.php/NVIDIA_Optimus

Might need to follow this guide as it will be good to utilise a laptop cost 2.1k.

After s good disk clone :wink:

1 Like