Boot error

I get the following message on boot:
“Failed to start Remount Root and Kernel File Systems”
link:Failed to start Remount Root and Kernel File Systems

I followed the link, but it didn’t help
fstab:

[code]# /dev/sda8
UUID=5a58de1e-0373-4e1a-a0d4-c1f4eefa3d / ext4 defaults,noatime 0 1

/dev/sda5

UUID=39f23cab-3322-438e-becd-56e468346656 swap swap defaults,noatime 0 2 [/code]

[code] vmc@archlabs ~ % systemctl status systemd-remount-fs.service :frowning:
● systemd-remount-fs.service - Remount Root and Kernel File Systems
Loaded: loaded (/usr/lib/systemd/system/systemd-remount-fs.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Sun 2018-04-22 18:28:10 PDT; 10min ago
Docs: man:systemd-remount-fs.service(8)
https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
Process: 227 ExecStart=/usr/lib/systemd/systemd-remount-fs (code=exited, status=1/FAILURE)
Main PID: 227 (code=exited, status=1/FAILURE)

Apr 22 18:28:10 archlabs systemd-remount-fs[227]: mount: /: can’t find UUID=5a58de1e-0373-4e1a-a0d4-c1f4eefa3d.
Apr 22 18:28:10 archlabs systemd-remount-fs[227]: /usr/bin/mount for / exited with exit status 1.
Apr 22 18:28:10 archlabs systemd[1]: systemd-remount-fs.service: Main process exited, code=exited, status=1/FAILURE
Apr 22 18:28:10 archlabs systemd[1]: systemd-remount-fs.service: Failed with result ‘exit-code’.
Apr 22 18:28:10 archlabs systemd[1]: Failed to start Remount Root and Kernel File Systems.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.[/code]

edit: I’m unsure how to turn off any interptation of text. Not sure whay “/dev/sda5” is so huge, or the smiley face.

I would first verify the UUID’s are correct in your fstab.

What is the output of:

$ sudo blkid

Hi @verndog did you install AL on a gpt or mbr harddrive? Also, is your system set up as dual boot?

Yes, dual boot. mbr install. and yes, uuid matches.

I think I found the problem:

vmc@archlabs ~ % cat /proc/mounts
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
sys /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
dev /dev devtmpfs rw,nosuid,relatime,size=1853904k,nr_inodes=463476,mode=755 0 0
run /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
/dev/sda8 / ext4 rw,relatime,data=ordered 0 0
securityfs /sys/kernel/security securityfs rw,nosuid,nodev,noexec,relatime 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
tmpfs /sys/fs/cgroup tmpfs ro,nosuid,nodev,noexec,mode=755 0 0
cgroup2 /sys/fs/cgroup/unified cgroup2 rw,nosuid,nodev,noexec,relatime,nsdelegate 0 0
cgroup /sys/fs/cgroup/systemd cgroup rw,nosuid,nodev,noexec,relatime,xattr,name=systemd 0 0
pstore /sys/fs/pstore pstore rw,nosuid,nodev,noexec,relatime 0 0
bpf /sys/fs/bpf bpf rw,nosuid,nodev,noexec,relatime,mode=700 0 0
cgroup /sys/fs/cgroup/cpu,cpuacct cgroup rw,nosuid,nodev,noexec,relatime,cpu,cpuacct 0 0
cgroup /sys/fs/cgroup/devices cgroup rw,nosuid,nodev,noexec,relatime,devices 0 0
cgroup /sys/fs/cgroup/net_cls,net_prio cgroup rw,nosuid,nodev,noexec,relatime,net_cls,net_prio 0 0
cgroup /sys/fs/cgroup/blkio cgroup rw,nosuid,nodev,noexec,relatime,blkio 0 0
cgroup /sys/fs/cgroup/memory cgroup rw,nosuid,nodev,noexec,relatime,memory 0 0
cgroup /sys/fs/cgroup/rdma cgroup rw,nosuid,nodev,noexec,relatime,rdma 0 0
cgroup /sys/fs/cgroup/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset 0 0
cgroup /sys/fs/cgroup/pids cgroup rw,nosuid,nodev,noexec,relatime,pids 0 0
cgroup /sys/fs/cgroup/perf_event cgroup rw,nosuid,nodev,noexec,relatime,perf_event 0 0
cgroup /sys/fs/cgroup/freezer cgroup rw,nosuid,nodev,noexec,relatime,freezer 0 0
cgroup /sys/fs/cgroup/hugetlb cgroup rw,nosuid,nodev,noexec,relatime,hugetlb 0 0
systemd-1 /proc/sys/fs/binfmt_misc autofs rw,relatime,fd=35,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=10966 0 0
debugfs /sys/kernel/debug debugfs rw,relatime 0 0
hugetlbfs /dev/hugepages hugetlbfs rw,relatime,pagesize=2M 0 0
mqueue /dev/mqueue mqueue rw,relatime 0 0
configfs /sys/kernel/config configfs rw,relatime 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev 0 0
tmpfs /run/user/1000 tmpfs rw,nosuid,nodev,relatime,size=378492k,mode=700,uid=1000,gid=985 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
gvfsd-fuse /run/user/1000/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=985 0 0

fstab orignally had data=ordered, but I removed it:

/dev/sda8
UUID=5a58de1e-0373-4e1a-a0d4-c1f4eefa3d / ext4 defaults,noatime 0 1
boot line:

linux /boot/vmlinuz-linux root=UUID=5a58de1e-0373-4e1a-a0d4-c1f4eefa3d34 rw splash quiet

Somewhere its being told to still used data=ordered, from the proc/mounts info
Also from mount command I get the same data=ordered:

/dev/sda8 on / type ext4 (rw,relatime,data=ordered)

I was thinking you only really need noatime enabled.

I was thinking on re-working fstab. Thinks for tip.

This is my fstab if it helps.


UUID=deb6263e-55d9-4b33-9eb4-25d96b23158d /            				ext4    		defaults,noatime,discard  				0 1
UUID=f50f1d01-cc71-4d72-acb6-f3d7d70c2e30 /home        				ext4    		defaults,noatime  					0 2

UUID=a9de30d6-dd5e-47a2-8af8-daf3a73266db swap         				swap    		defaults,noatime,discard  				0 0
tmpfs                                     /tmp         				tmpfs   		defaults,noatime,mode=1777  				0 0

The first entry is where ArchLabs is installed which is on a SSD hence the extra options.

Thanks, I’ll try your. I removed defaults , but that didn’t work.

Ok, that didn’t work either, but look at this:

% systemctl status systemd-remount-fs.service
● systemd-remount-fs.service - Remount Root and Kernel File Systems
Loaded: loaded (/usr/lib/systemd/system/systemd-remount-fs.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Sun 2018-04-22 23:14:06 PDT; 45s ago
Docs: man:systemd-remount-fs.service(8)
https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
Process: 239 ExecStart=/usr/lib/systemd/systemd-remount-fs (code=exited, status=1/FAILURE)
Main PID: 239 (code=exited, status=1/FAILURE)

Apr 22 23:14:06 archlabs systemd-remount-fs[239]: mount: /: can’t find UUID=5a58de1e-0373-4e1a-a0d4-c1f4eefa3d.
Apr 22 23:14:06 archlabs systemd-remount-fs[239]: /usr/bin/mount for / exited with exit status 1.
Apr 22 23:14:06 archlabs systemd[1]: systemd-remount-fs.service: Main process exited, code=exited, status=1/FAILURE
Apr 22 23:14:06 archlabs systemd[1]: systemd-remount-fs.service: Failed with result ‘exit-code’.
Apr 22 23:14:06 archlabs systemd[1]: Failed to start Remount Root and Kernel File Systems.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

% sudo blkid

/dev/sda1: LABEL=“WindowsPRO” UUID=“E88C81DA8C81A3A2” TYPE=“ntfs” PARTUUID=“c881d74c-01”
/dev/sda2: LABEL=“ntfs” UUID=“E2A61116A610ECB3” TYPE=“ntfs” PARTUUID=“c881d74c-02”
/dev/sda5: UUID=“39f23cab-3322-438e-becd-56e468346656” TYPE=“swap” PARTUUID=“c881d74c-05”
/dev/sda6: LABEL=“xfce” UUID=“b2b71600-2085-4cd6-8c63-c2be10e4a467” TYPE=“ext4” PARTUUID=“c881d74c-06”
/dev/sda7: LABEL=“manjaro” UUID=“4e775ad7-588d-4742-9e28-43a4973004c3” TYPE=“ext4” PARTUUID=“c881d74c-07”
/dev/sda8: UUID=“5a58de1e-0373-4e1a-a0d4-c1f4eefa3d34” TYPE=“ext4” PARTUUID=“c881d74c-08”
/dev/sda9: LABEL=“SAVE” UUID=“e9d12e7c-7f32-4b2d-9296-c11df97f80f9” TYPE=“ext4” PARTUUID=“c881d74c-09”

The blkid and fstab matches. I’m thinking now its how I told AL to assign EXT4. There was some extra journal info added. A choice that I never seen before.

Did you format your root and home partitions as ext4 or ext2? You may have a mixture of both. You can check using gparted to see if this is the case.

Only ext4. ubuntu/debian user for years. Fairly new to the arch way. As I recall though, arch keeps a file that records all input during install. I need to look for that file and see what I added when selecting ext4.

Just wanted to make sure mixing partition type wasn’t an issue. I have seen someone use both, then he couldn’t boot into AL.

@OP: please post the full content of /etc/fstab and the output of

grep sda8 /proc/self/mounts

Thanks!

(For a good markdown tutorial see https://guides.github.com/features/mastering-markdown/)

grep sda8 /proc/self/mounts

/dev/sda8 / ext4 rw,relatime,data=ordered 0 0

fstab

UUID=5a58de1e-0373-4e1a-a0d4-c1f4eefa3d / ext4 defaults,noatime 0 1
UUID=39f23cab-3322-438e-becd-56e468346656 none swap defaults 0 0

Yes, that’s the problem. But how to remove the data=ordered?

I’ve been trying to figure that out for hours. Its not fstab issue.
Apparently its not data-ordered that’s the problem. Here’s my ubuntu partition, and it has no errors:

$ mount -l -t ext4
/dev/sda6 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered) [xfce]
Now I’m unsure what the problem is.

Is that the full content of /etc/fstab?

Try this:

mv /etc/fstab{,.bak}
reboot

You don’t actually need an fstab at all if you only have a single root partition so let’s see what happens without one.

2 Likes

Ok. Something different. Screen flash black, then boot. Result:

● systemd-remount-fs.service - Remount Root and Kernel File Systems
Loaded: loaded (/usr/lib/systemd/system/systemd-remount-fs.service; static; vendor preset>
Active: inactive (dead)
Condition: start condition failed at Tue 2018-04-24 06:35:46 PDT; 1min 18s ago
└─ ConditionPathExists=/etc/fstab was not met
Docs: man:systemd-remount-fs.service(8)
https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems

Now just info regarding the missing fstab.

So there were no errors during the boot process?

Does grep sda8 /proc/self/mounts have the same output?

$ grep sda8 /proc/self/mounts
/dev/sda8 / ext4 rw,relatime,data=ordered 0 0

So now what to do about fstab? Why does it not see the correct UUID, per the systemctl status?

I generated a new fstab, and it went south quickly. Didn’t like gvfs user 1000. So I edited out that portion, and now it works perfectly:

'# Static information about the filesystems.
'# See fstab(5) for details.

'# /dev/sda8 LABEL=openbox
UUID=5a58de1e-0373-4e1a-a0d4-c1f4eefa3d34 / ext4 rw,relatime,data=ordered 0 1
'# /dev/sda5
UUID=39f23cab-3322-438e-becd-56e468346656 none swap defaults 0 0
'# bpf
'# bpf /sys/fs/bpf bpf rw,nosuid,nodev,noexec,mode=700 0 0
'# gvfsd-fuse
'# gvfsd-fuse /run/user/1000/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,user_id=1000,group_id=9850 0
(ignore the single quote, else the fonts become huge)