ArchLabs Linux

Bluetooth Autostart Disable?

Good Day Labsters,

I am having an issue with my Dell laptop, which I have had before, where my Bluetooth is on and activated after each boot. The bluetooth icon appears in my polybar tray and is driving me insane.
There is no bluetooth.desktop file in autostart.

Where should I be looking? Maybe soft blocking bluetooth? Please help.

Thank You

please posted answer: systemctl status bluetooth.service

2 Likes

@ector is correct, check with systemctl and disable the service

1 Like

Thanks for the suggestion @ector and @nate :

[user@AL] systemctl status bluetooth.service

● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disab>
   Active: active (running) since Tue 2018-05-01 13:20:05 SAST; 4min 47s ago
     Docs: man:bluetoothd(8)
 Main PID: 400 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4915)
   Memory: 3.2M
   CGroup: /system.slice/bluetooth.service
           └─400 /usr/lib/bluetooth/bluetoothd

May 01 13:20:03 enigma bluetoothd[400]: Bluetooth daemon 5.49
May 01 13:20:05 enigma bluetoothd[400]: Starting SDP server
May 01 13:20:05 enigma bluetoothd[400]: Bluetooth management interface 1.14 initialized
May 01 13:20:03 enigma systemd[1]: Starting Bluetooth service...
May 01 13:20:05 enigma systemd[1]: Started Bluetooth service.

I don’t mind the service running, because I do use Bluetooth occasionally. I’m assuming that if the bluetooth.service is disabled, I won’t be able to start it without ?

systemctl enable bluetooth.service

I want the service to be active, but shouldn’t enable bluetooth upon startup automatically. I did this before, but can’t remember what I did to solve the issue.

I also changed

AutoEnable=False

in /etc/bluetooth/main.conf

It’s not working. Apparently Bluetooth should be off by default?

1 Like

Fixed it!

sudo rm /etc/xdg/autostart/blueman.desktop
1 Like

Not sure if this is the correct way to do it, i lack some knowledge here.
But, speaking for my case, i disable bluetooth on startup through
systemctl disable bluetooth.service
and made a terminal shortcut(alias) to start it when needed
systemctl start bluetooth.service
You could handle blueman as well I guess.

Might be wrong but enable create a symlink so on startup systemd start the corresponding service.
Anyway, thanks for the blueman advice, was looking for it too.

1 Like

Glad to hear you found it

Helpful topic, I was crazy trying to setup my BT3.0 mouse (that runs okay in the same machine under W10) until I found this.
Thanks a lot @ector, @nate @fatboy @gazeka74 !.
Jes.

1 Like