'blacklist: Problem blacklisting hash (-13)' errors on boot

I hope I can post this here and not in the Basic Help - I am feeling more confident (fall imminent, no doubt :smiley:)

blacklist: Problem blacklisting hash (-13)

Anyone else getting these errors at boot?

Doesnt seem to affect the smooth running AL

leigh@archlabs ~ % uname -a
Linux archlabs 5.19.1-arch2-1 #1 SMP PREEMPT_DYNAMIC Thu, 11 Aug 2022 16:06:13 +0000 x86_64 GNU/Linux

They dont appear on LTS

leigh@archlabs ~ % uname -a
Linux archlabs 5.15.60-1-lts #1 SMP Thu, 11 Aug 2022 14:09:59 +0000 x86_64 GNU/Linux
leigh@archlabs ~ %

Seems to be known issue:

Do I just wait for them to hopefully go away on a future kernel update?

That’s what I tried with my ex-wife, it didn’t work. I had to break the system.




Excellent !


Should fiind & stay with the LTS version. It’s usually a little more stable. :grinning:


Now that’s a good one!

ARCH has an LTS version?
I’m ARCH illiterate.


Wonder if it s on AL s installer. Or one installs it him/herself on Arch s AUR.


Try 5.19.2 to see if it’s been fixed.

I’m considering Linux From Scratch :rofl: Love me breakage :wink: Back on topic: @leigh : 1. wait shortly for the newer kernel. 2. slow down to LTS, it will be refreshing anyway (vs the daily FOMO) 3. a newer AL iso is around the corner, but I don’t know the ETA.


I just started getting this error too but I think it was after updating my BIOS which reset a bunch of settings.
Have you changed any of your BIOS settings recently?

I’m on an MSI X570 Tomahawk WiFi motherboard btw if that helps.

Apparently the errors come from a recent kernel change and can be avoided by clearing secure boot keys.


1 Like

Thanks @ChrisLane
How’s this for a late answer?

I cleared my secure boot keys

In case anyone else like me didnt know how to do it - entered into BIOS, under security was an ‘enable manage secure boot’ option (cant remember exactly), did that then cleared all keys (had option to backup first so I did)

problem solved, the errors went away!

could well be a ‘car running better after filling up’ type thing , but seems to boot faster now too


NB: I had already updated various times and am now on 5.19.13, but the blacklisting hash (-13) errors were still hanging around

1 Like

Yes indeed, booting with an LTS kernel removes those errors.

1 Like

Glad that it worked for you @ukemi

Welcome aboard !