Autotiling for sway & i3

@nwg Witaj Piotr, I’ve decide to try your autotiling. Consider me your official ‘stupid user’. The source of all ‘stupid user’ problems. :wink:

  • I installed using pip (it worked, yay!)

  • Here is the autostart command I used…

exec_always --no-startup-id autotiling -w 1 7 

I got nothing…

Next, I tested the following cli command:

autotiling -w 1

I get the following error message:

    $ autotiling -w 1
    usage: autotiling [-h] [--debug] [--version]
    autotiling: error: unrecognized arguments: -w 1

the command ‘autotiling’ with no arguments does not error.

I assume two things from my quick test:

  1. I have the start command wrong (the docs are incorrect and/or I’m not a very bright bulb :upside_down_face:
  2. This will only work with windows that are “not” flagged to float. If true, this should be in your docs for slow learners like me. :slight_smile:

I hope?!?! this helps.

Sorry, PyPi version is 1.1, and you need at least 1.4. I was made publish the script in PyPi by a contributor, but later I forgot how it was done. Honestly I don’t think autotiling should be published there at all.

Please use an up to date package.

No problem. You probably ought to fix the pip pointer issue on your github.

I will try something more current. :slight_smile:

FWIW I just did an update/ upgrade and tried opening multiple instance of Thunderbird windows on an autotiling workspace. Nothing seems to happen. I am running a vanilla version of i3wm. :frowning: I am pretty certain I am missing some critical setting(s).

Just change the source array as described by @haawda.

So from this:

source=("https://github.com/nwg-piotr/autotiling/archive/v"$pkgver".tar.gz")

To this:

source=("$pkgname-$pkgver.tar.gz::https://github.com/nwg-piotr/autotiling/archive/v$pkgver.tar.gz")

^ That renames the tarball after it has been downloaded.

I’ve used the same technique for the Alpine package: APKBUILD\autotiling\testing - aports - Alpine packages build scripts

The ArchWiki has a warning about this:

https://wiki.archlinux.org/index.php/PKGBUILD#source

1 Like

Hmmm… I have no idea what could be the reason… But TBH, my i3 broke down months ago, and I haven’t tested several last versions of the script there. I’ll try to fix it and reproduce your problem.

Many thanks! I had no idea it worked like this. Autotiling 1.5 is ready to release for weeks. I’ll fix the issue by the way.

I am happy to help. Let me know when you need things broken! :wink:

1 Like

Well, I couldn’t confirm the issue on my setup. Each instance of Thunderbird opens as expected.

Autotiling 1.5 released

Alpine Linux merge request submitted.

1 Like

Thank you!

Top @Head_on_a_Stick @nwg

@nwg The new version opens windows like that on my machine. So I guess it works. :slight_smile: I assume this works only with windows/apps that are NOT floating.

Indeed.

            # Let's exclude floating containers, stacked layouts, tabbed layouts and
            # full screen mode
            if (not is_floating
                    and not is_stacked
                    and not is_tabbed
                    and not is_full_screen):
                new_layout = "splitv" if con.rect.height > con.rect.width else "splith"
1 Like

Thanks nwg

And you can set it to any combo of workspaces nice.

How do I use the floating script.

What do you mean? The script ignores floating containers.

Sorry was a late night, not thinking straight.

1 Like

Further Azote-related updates will be published here.