Automatic login with my user


#1

When I start my archlabs, it logins automatically with my user. How can I make it to ask me the password?


#2

Hi @abenitez , you can edit /etc/lightdm/lightdm.conf and look for the section starting with [Seat:*] then comment out the entry that looks like this autologin-user=username
There is a topic Here about it.
I know it works with openbox, let me know if works for you.
See ya


#3

You can add this step to make it official

sudo gpasswd -d $USER nopasswdlogin

#4

Bumping this thread because I have the same problem.
@7im4pple 's solution does not work and there’s no /lightdm/ folder or lightdm.conf file in my /etc/ folder.
I’m using the latest version.


#5

You don’t have lightdm installed… need to add it. Or whichever login manager you want to use… if you run al-hello there is an option to install it from there also.


#6

This solved it. Thank you so much.


#7

Glad that you got it fixed in there @plebeu


#8

what if I wanted to use slim as my dm?