ArchLabs works well but slow to start

I really like archlabs openbox but it takes about 2 minutes for it to start up. Everything works as it should when it finally boots up.
I am running open box on slackware and about 10 to 15 seconds boot up is all it needs.
Arch runs very well on a 1.5 two core 18 year old machine.
any ideas appreciated

More details would help. How old is the install? Any recent changes?


Swap partition can’t be found will cause long startup times.

Someone smarter that me will come along to help.

Also welcome to the forum.

post systemd-analyze blame . . .


Hope you get it sorted, never experienced this.

That was one of the main reasons I gave up multi-booting. The new install would format an existing swap partition belonging to another distro. Debian is the worst; it will latch onto every swap partition it can find. Most installers you can limit that but once in a while.

a start job is running for dev-disk…" adding 1.5 minutes to the boot.

Ooh, that’s nice to know! :+1:

1 Like

@zrdc28r - run that command @knob posted.

Welcome to the forum.

OP posted twice after my initial response, then deleted them, making me think they found an answer to the issue. And hasn’t been back since.

1 Like
3.211s NetworkManager-wait-online.service
1.429s systemd-modules-load.service
 655ms systemd-binfmt.service
 617ms systemd-timesyncd.service
 555ms reflector.service
 263ms dev-nvme0n1p2.device
 193ms ldconfig.service
 181ms systemd-tmpfiles-clean.service
 110ms cups.service
  87ms systemd-udev-trigger.service
  74ms user@1000.service
  74ms lvm2-monitor.service
  72ms boot.mount
  61ms nmb.service
  56ms systemd-tmpfiles-setup.service
  51ms upower.service
  50ms smb.service
  50ms systemd-journal-flush.service
  37ms systemd-udevd.service
  37ms systemd-logind.service
  30ms accounts-daemon.service
  29ms systemd-journald.service
  27ms udisks2.service
  22ms systemd-tmpfiles-setup-dev.service
  21ms NetworkManager.service
  21ms systemd-fsck@dev-disk-by\x2duuid-8F29\x2dC938.service
  19ms lm_sensors.service
  19ms systemd-sysusers.service
  17ms dbus.service
  15ms colord.service
  14ms systemd-random-seed.service
  14ms systemd-journal-catalog-update.service
  11ms polkit.service
  10ms dev-hugepages.mount
  10ms dev-mqueue.mount
  10ms sys-kernel-debug.mount
  10ms sys-kernel-tracing.mount
  10ms kmod-static-nodes.service
  10ms modprobe@fuse.service
  10ms modprobe@drm.service
   9ms modprobe@configfs.service
7ms systemd-remount-fs.service
   7ms sys-fs-fuse-connections.mount
   6ms swapfile.swap
   6ms systemd-update-utmp.service
   6ms sys-kernel-config.mount
   4ms user-runtime-dir@1000.service
   3ms systemd-user-sessions.service
   3ms systemd-sysctl.service
   3ms systemd-update-done.service
   2ms rtkit-daemon.service
   1ms proc-sys-fs-binfmt_misc.mount
   1ms tmp.mount

Need we really Network Manager, Took a lot of Boot- Time :frowning:

No, there are other network management programs you can use that might be faster.

Ok, this is the configuration as shipped from archlabs, what do I need to do to optimize this, does it even make sense, “It” boots fast enough now…

maybe the prompt reaction has stunned / frightened him :slight_smile:

Arch Wki Network Configuration

Network Configuration

Scroll down a bit and you’ll find the Network Managers available with lonks to their own wiki page. Decidexwhat’s best based on your set up.

Please start a new thread if you need help with your network.

1 Like

With one of the early releases of ArchLabs I had an issue where it took a long time to boot

Turned out to be an indexing of an internal database - man pages I think. Could take 2-3 minutes sometimes.

A user (who has not been around for a while) wrote a systemd hook to get around it. I’m still searching for that post

Found it -

This was the issue -

    4min 55.327s updatedb.service
         37.144s man-db.service

@Dobbie03 - found this page about it

@pangolin wrote his own fix for it a while back.


thx PackRat for your hint,

so i will start a change from NetworkManager to systemd-networkd

and check if this config boots faster…

If i go in to trouble, i make a new thread as you recommended

cu, stephan

1 Like

The present install is about 2 months old, and I did make a swap file. This is not a dual boot I only have arch labs. I appreciate the info and will get into running and checking the suggestions. It runs so well on the the old core duo machine and has been fun to play with.

1 Like

Knob posted the way I solved my problem. systemd-analyze blame told me that the longest time for an app to load was about 6 seconds, all toll about 45 seconds. The rest of the time was due to bios settings on the old 18 year old machine.
Thanks to everyone that helped with suggestions.
After it is up running there is very little difference in it and the i5 & i7 machines.