Archlabs won't boot after fresh install

Hey all.

I’m new to archlabs, and wanted to install the distro on an empty hardrive via a usb with the live image on it. I made my partitions in gparted (an ext4 partition for root, and one linux-swap for swap). I followed the directions of the installer, and installed the bootloader on my harddrive, but when I go to reboot my computer, there is no grub menu, and my computer can’t detect the operating system. (I’m writing this from the live usb disk lol). I’ve tried installing twice already and have gotten the same results. Any help would be nice, Thanks.

Hello @theUndertaker and welcome to the forum.
Please verify if you need/want to create an efi partition , that is if your BIOS is set up to boot in UEFI modality.
The second suggestion would be to install the “testing” iso you can find here.
Please read this post for more chances of a successful installation.
No need to worry because the release is rock solid, i have been using it since the beginning with no issues at all

2 Likes

Quite Monday at work, you can tell everyone is on holiday :sweat_smile:

1 Like

Got the same problem. Try to install older version, in my case 2018.02 worked for me.

Seems like a Hit & Miss concerning our respective hardware I guess.

If you don’t have an EFI system partition then try selecting CSM or Legacy mode from your firmware (“BIOS”) options to let your machine boot in non-UEFI mode.

You probably have GRUB installed in non-UEFI mode, this can be confirmed from the live environment by using a hex editor to read the MBR:

dd if=/dev/sda bs=512 count=1 | xxd

There should be a “GRUB .Geom.Hard Disk.Read.Error” message in the output.

If you want to switch to a UEFI system then remount /boot to an EFI system partition (and change /etc/fstab) then re-install the kernel and install the bootloader in UEFI mode:

https://wiki.archlinux.org/index.php/GRUB#Installation_2

1 Like

Hi, after several hours of tinkering, I’ve finally got this thing to work, although its not optimal. I installed the testing version, but I got the same problem. The same is true for trying everything else suggested in this post. The only thing that allowed me to use this distro was installing some other flavor of linux (i just did fedora because of its easy and reliable installing process), and then installed archlabs alongside of fedora. I’m really not sure what else to do, and I want to completely remove fedora in the future, Thanks anyways.

Hi there,
I tried installing the testing version, but the same problem occurred. The only solution that worked was installing another linux distro, and dual booting with archlabs, allowing me to at least see the Grub menu. Thanks anyways :slight_smile:

1 Like

^^^
@anon37345411
@poiseman
@Head_on_a_Stick
@altman

Hi @theUndertaker , I don’t know what to suggest to solve your problem as for the few info I have it could be anything.
I am sure someone will came up soon with the right idea.
Thank you for keep trying, Archlabs is great to use and is also fun to learn how to make it work the way you like it.

To add to pippo s,

Hardware list might help you out a little bit mate.

1 Like

Did you try booting with CSM (“Legacy” mode) engaged?

Did you check the MBR for any evidence of GRUB?

Please post the full output of efibootmgr -v, thanks!

1 Like

I did not try those two things, I don’t really know what that means or what to do with it (I’m very new to linux). However, the output of that command is “EFI variables are not supported on this system.”

Thanks!

This:

means that you are already booted in non-UEFI mode.

Is your machine UEFI capable?

To allow yourself to be rid of Fedora then install GRUB to your hard drive in non-UEFI mode:

https://wiki.archlinux.org/index.php/GRUB#Installation

You may need to configure the bootloader afterwards with grub-mkconfig -o /boot/grub/grub.cfg

3 Likes

My machine is not UEFI capable. I’m going to follow your advice on installing GRUB tomorrow morning. Thank you!

1 Like

What altman said.

What are the computer specs? Laptop? HP/Toshiba?

Was there a version of Windows pre-installed?

1 Like

This is the output when i ran “sudo lshw -short”

H/W path Device Class Description

system HP ZBook 15 (F2P53UT#ABA)
/0 bus 1909
/0/f memory 64KiB BIOS
/0/0 processor Intel® Core™ i7-4700MQ CPU @ 2.40GHz
/0/0/2 memory 32KiB L1 cache
/0/0/3 memory 256KiB L2 cache
/0/0/4 memory 6MiB L3 cache
/0/1 memory 32KiB L1 cache
/0/7 memory 8GiB System Memory
/0/7/0 memory 4GiB SODIMM DDR3 Synchronous 1600 MHz (0.6 ns)
/0/7/1 memory DIMM [empty]
/0/7/2 memory 4GiB SODIMM DDR3 Synchronous 1600 MHz (0.6 ns)
/0/7/3 memory DIMM [empty]
/0/100 bridge Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller
/0/100/1 bridge Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller
/0/100/1/0 display GK107GLM [Quadro K1100M]
/0/100/1/0.1 multimedia GK107 HDMI Audio Controller
/0/100/14 bus 8 Series/C220 Series Chipset Family USB xHCI
/0/100/14/0 usb3 bus xHCI Host Controller
/0/100/14/0/1 bus USB 2.0 Hub
/0/100/14/0/1/3 input Dell USB Entry Keyboard
/0/100/14/0/5 generic VFS495 Fingerprint Reader
/0/100/14/0/6 multimedia USB Audio Device
/0/100/14/0/7 multimedia HP HD Webcam
/0/100/14/0/9 input USB Receiver
/0/100/14/0/c communication Bluetooth wireless interface
/0/100/14/1 usb4 bus xHCI Host Controller
/0/100/16 communication 8 Series/C220 Series Chipset Family MEI Controller #1
/0/100/19 enp0s25 network Ethernet Connection I217-LM
/0/100/1a bus 8 Series/C220 Series Chipset Family USB EHCI #2
/0/100/1a/1 usb1 bus EHCI Host Controller
/0/100/1a/1/1 bus USB hub
/0/100/1b multimedia 8 Series/C220 Series Chipset High Definition Audio Controller
/0/100/1c bridge 8 Series/C220 Series Chipset Family PCI Express Root Port #1
/0/100/1c.4 bridge 8 Series/C220 Series Chipset Family PCI Express Root Port #5
/0/100/1c.6 bridge 8 Series/C220 Series Chipset Family PCI Express Root Port #7
/0/100/1c.6/0 wlo1 network Centrino Advanced-N 6235
/0/100/1c.7 bridge 8 Series/C220 Series Chipset Family PCI Express Root Port #8
/0/100/1c.7/0 generic RTS5249 PCI Express Card Reader
/0/100/1d bus 8 Series/C220 Series Chipset Family USB EHCI #1
/0/100/1d/1 usb2 bus EHCI Host Controller
/0/100/1d/1/1 bus USB hub
/0/100/1f bridge QM87 Express LPC Controller
/0/100/1f.2 storage 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode]
/0/100/1f.3 bus 8 Series/C220 Series Chipset Family SMBus Controller
/1 power AR08083
/2 power ST09073

Just tried this, and it worked! Thanks a lot! For future reference, is there a way to install grub on this distro if i’m on the live version on a usb stick? If I’m ever in this scenario again, I don’t want to have to install fedora to use Archlabs.

Yes, you can chroot from the live session and install grub.

I think there is section for that in the link that was provided; maybe a separate entry in the Arch Wiki.

^ Actually a chroot is not needed to install GRUB :slight_smile:

See this section of the ArchWiki:

https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks#BIOS

It refers to installing GRUB to a USB stick but it works just as well with a hard drive.

1 Like