Archlabs repos

I read that I must have changed my /etc/pacman.conf since The 4th of may 2021.
Ok I just did it.
Unfortunately I didn’t make a copy of the old one.
But now if comment the archlabs-testing stanza

[archlabs-testing]
#Server = https://bitbucket.org/archlabslinux/$repo/raw/master/$arch

pacman -Syyu won’t work:
Synchronisation des bases de données de paquets…erreur : la synchronisation de toutes les bases de données a échoué (aucun serveur configuré pour le dépôt)

So I uncommented this line, cleaned the cache and updated with pacman -Syyu

pacman worked but then:

erreur : échec de récupération du fichier « b43-firmware-6.30.163.46-3-x86_64.pkg.tar.zst » depuis bitbucket.org : Maximum file size exceeded

I’m stuck now. I didn’t want to use the testing branch. Just making updates like before.

Wonder if the server s down for some reasons @bigdatalebowsky

Or check later on if it s working. Is it on Testing Repo only that it does that or all of them !

Edit; I would edit my thread tittle to Testing Repo, it might also help you out in order to find a solution.

Edit2: Wonder if Testing still exists or such, but I can be wrong here. Just a tought.

Also, was your install updated regularly or it hasn t been updated for quiet some times.

Everday, I swear ! Twice a day sometimes !

Updates used to work before I changed my pacman.conf. And I don’t remember I used the testing branch – or does AUR needs it ?

Seems that the repo paths are changed on bitbucket & github.

For a quick workaround, in your /etc/pacman.conf, change [archlabs] section to,

[archlabs]

#Server = https://bitbucket.org/archlabslinux/$repo/raw/master/$arch

#Server = https://github.com/ArchLabs/$repo/raw/master/$arch

Server = https://sourceforge.net/projects/archlabs-repo/files/$repo/$arch

You don’t need to enable the testing repo.

Wonder if it s because of the test repo if enabled.

Is it still maintained @chroot . I don t know or went over that news.

Ok, thx for the comeback @bigdatalebowsky . Sometimes they re not always updated , so it s ok.

I did what @chroot told. Still same
No server configured for the repo
error.

Wow, please post results from this command;

cat /etc/pacman.conf

1 Like
#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
IgnorePkg = linux-headers linux
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
ILoveCandy
#TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# The multilib repositories are enabled by default in ArchLabs.
# If you don't run 32 bit applications you may comment them out

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

# [archlabs_unstable]
# Server = https://bitbucket.org/archlabslinux/$repo/raw/master/$arch

[archlabs-testing]
#Server = https://bitbucket.org/archlabslinux/$repo/raw/master/$arch

[archlabs]

Server = https://bitbucket.org/archlabslinux/$repo/raw/master/$arch

Server = https://github.com/ArchLabs/$repo/raw/master/$arch

Server = https://sourceforge.net/projects/archlabs-repo/files/$repo/$arch


I have
# [archlabs-testing]

And why?

IgnorePkg = linux-headers linux
2 Likes

Wonder what s wrong with that, would also think about keyring, might be it !

@Pinhead I think the IgnorePkg line was made by the downgrade package. I used it to have the same kernel longer . I think I can remove this line now.

And yes you’re right:
this damn # missing before [archlab-testing] was the reason why I had erros ! I would never have notice it !

All good now @bigdatalebowsky !

We always learn something .

Hi,
pacman -Syyu and pacman -Syu won’t work:

midfingr@archlabs ~ % sudo pacman -Syu
errore: Errore di GPGME: Dati assenti
:: Sincronizzazione dei database in corso...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlabs               14,4 KiB  19,8 KiB/s 00:01 [----------------------] 100%
errore: Errore di GPGME: Dati assenti
errore: failed to synchronize all databases (il database non è valido oppure è corrotto (firma PGP))
midfingr@archlabs ~ % sudo pacman -Syyu
errore: Errore di GPGME: Dati assenti
:: Sincronizzazione dei database in corso...
 core                  156,8 KiB  15,5 KiB/s 00:10 [----------------------] 100%
 extra                1719,1 KiB   130 KiB/s 00:13 [----------------------] 100%
 community               7,0 MiB   418 KiB/s 00:17 [----------------------] 100%
 multilib              170,8 KiB  16,8 KiB/s 00:10 [----------------------] 100%
 archlabs               14,4 KiB  1252   B/s 00:12 [----------------------] 100%
errore: impossibile scaricare il pacchetto 'archlabs.db' da bitbucket.org : Connection time-out
errore: Errore di GPGME: Dati assenti
errore: failed to synchronize all databases (il database non è valido oppure è corrotto (firma PGP))
midfingr@archlabs ~ % cat /etc/pacman.conf
#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
ILoveCandy
#TotalDownload
CheckSpace
#VerbosePkgLists
ParallelDownloads = 5

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# The multilib repositories are enabled by default in ArchLabs.
# If you don't run 32 bit applications you may comment them out

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

# [archlabs-testing]
# Server =  https://github.com/ArchLabs/$repo/raw/master/$arch
# Server =  https://bitbucket.org/archlabslinux/$repo/raw/master/$arch

#[archlabs]
#Server = https://github.com/ArchLabs/$repo/raw/master/$arch
#Server = https://bitbucket.org/archlabslinux/$repo/raw/master/$arch
#Server = https://sourceforge.net/projects/archlabs-repo/files/$repo/$arch

[archlabs]
Server = https://bitbucket.org/archlabslinux/$repo/raw/master/$arch
Server = https://github.com/ArchLabs/$repo/raw/master/$arch
Server = https://sourceforge.net/projects/archlabs-repo/files/$repo/$arch 

# vim:ft=config
midfingr@archlabs ~ % 


Best regards
Edit
pacman upgrades if you delete archlabs repo.
cheers

I would try to update the keyring & see what it does @ectorom

Google Translated from your post above;


error: unable to download package 'archlabs.db' from bitbucket.org: Connection time-out
error: GPGME error: No data
error: failed to synchronize all databases (the database is invalid or corrupt (PGP signature))
midfingr@archlabs ~ % sudo pacman-key --populate
==> Aggiunta delle chiavi da archlabs.gpg in corso...
==> Aggiunta delle chiavi da archlinux.gpg in corso...
gpg: error reading key: Nessuna chiave pubblica
==> Disabilitazione delle chiavi revocate nel keyring in corso...
  -> Disabled 1 keys.
==> Aggiornamento del database in corso...
gpg: il prossimo controllo del trustdb sarà fatto il 2022-10-11
midfingr@archlabs ~ % sudo pacman -Syu          
errore: Errore di GPGME: Dati assenti
:: Sincronizzazione dei database in corso...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlabs               14,4 KiB  2,64 KiB/s 00:05 [----------------------] 100%
errore: Errore di GPGME: Dati assenti
errore: failed to synchronize all databases (il database non è valido oppure è corrotto (firma PGP))
midfingr@archlabs ~ % sudo pacman -Sy archlinux-keyring && pacman -Su
errore: Errore di GPGME: Dati assenti
:: Sincronizzazione dei database in corso...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlabs               14,4 KiB  2,53 KiB/s 00:06 [----------------------] 100%
errore: Errore di GPGME: Dati assenti
errore: failed to synchronize all databases (il database non è valido oppure è corrotto (firma PGP))

Here removed the archlabs repo


midfingr@archlabs ~ % sudo pacman -Syu                               
:: Sincronizzazione dei database in corso...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Aggiornamento del sistema in corso...
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...

Pacchetti (12) alsa-card-profiles-1:0.3.59-2  dhclient-4.4.3.P1-1
               firefox-105.0.3-1  flac-1.4.1-2  glibc-2.36-6
               imagemagick-7.1.0.50-1  libcdio-2.1.0-3  libgpg-error-1.46-1
               libical-3.0.15-1  librsvg-2:2.55.1-1  pipewire-1:0.3.59-2
               vi-1:070224-6

Dimensione totale dei pacchetti da scaricare:    82,93 MiB
Dimensione totale dei pacchetti da installare:  325,58 MiB
Dimensione netta dell'aggiornamento:             -3,77 MiB

:: Vuoi procedere con l'installazione? [S/n]n

I only have the problem with your repos.

midfingr@archlabs ~ % sudo pacman -Syu
errore: Errore di GPGME: Dati assenti
:: Sincronizzazione dei database in corso...
 core is up to date
 extra                1719,1 KiB   482 KiB/s 00:04 [----------------------] 100%
 community               7,0 MiB   895 KiB/s 00:08 [----------------------] 100%
 multilib is up to date
 archlabs               14,4 KiB  2,05 KiB/s 00:07 [----------------------] 100%
errore: Errore di GPGME: Dati assenti
errore: failed to synchronize all databases (il database non è valido oppure è corrotto (firma PGP))
midfingr@archlabs ~ % 


Cheers

That sux, have a look at this link,hope it s still up to date !

do you know where I can find .gz of the latest archlabs-keyring version?!