Archlabs May-iso on Mac-mini 4,1 (mid-2010)

Hi!
Now I have “the May-iso” downloaded.
I have been given a “quest/task” from a friend to install Archlabs on a Mac-mini 4,1.
I am having big troubles to get it to boot!

“pci 0000:05:00.0
error -61
assigning properties”

It doesnt go further than that and the fan i “screaming” so I turn it off!

What do I do with that?
According to Debian-wiki this is one of the “easy” macs to install linux into!?

womp

Maybe they mean easy for Debian. Did you try one of their iso? A stock Debian, not something like BL where there are a bunch of custom configurations. SharpBang should work -.

Thanks! SharpBang did boot easily but my friend wants AL installed!
Is that possible to accomplish?

womp

Probably, once you get past that error message. CPU related?

Did you do a search for installing Arch on a Mac-mini 4,1?

1 Like

Not there yet.
Found something interesting.
Changing lightdm conf file “logind-check-graphical=true” fixed my main Arc!hlabs system!
I noticed that lightdm won’t start after I have installed Archlabs so I will try that after install!

(what I wrote before was “mushy-brain”)

womp

It could be your hardware causing the problems…
Your mac mini comes from 2010 and is probably equal to a mid-range 2005-2007 desktop in terms of performance.
https://everymac.com/systems/apple/mac_mini/specs/mac-mini-core-2-duo-2.4-mid-2010-specs.html
How are you configuring your Archlabs install?

Does the ISO not boot or the installed system? In another thread, I read that you couldn’t boot the EndeavourOS ISO on that machine, hence the question.
You have pressed the option key, while booting the ISO? Only then you will see the option which medium you want to boot on a Mac.

Hi!!

I am an old mac-user. (Since 1995)

I have been researching this “mac-problem” I am now writing this from Mac-mini with Archlabs installed on it!! I am not ready yet because now I have gotten “half-way” and I am using nouveau driver. Even though nvidia drivers are faulty I find nouveau worse!

/etc/deault/grub and “nomodeset” to get it to boot (“e” at bootmenu for firsttime).
/etc/lightdm/lightdm.conf [lightdm] “check graphical=true” (to be on the safe side)

Next I will try to install nvidia. I am not 100% sure if there is a driver for geforce 320M!?

womp

1 Like

YES!!
I managed to get nvidia-340 installed and I am back in openbox and nvidia is loaded!
It is a remarkable difference even with this 10 year old card!

The bad news is that 340 is only supported “at the moment”. I have to stop xorg from updating to 1.21!!
I do not now how to do that but it is probably easier than downgrading right!?

womp

Hopefully nvidia will be supported for a while !

Top job @womp

1 Like

Does using the nvidia-340xx-dkms solve that issue for you? I have to use that for my ancient graphics card and updates to xorg occur without issue.

1 Like

Well for the moment it’s working great !
I always use 2 kernels so therefore I always use dkms too.
According to nvidia “340” the last to be supported by them so I think it’s a must to halt updates to xorg if I want to use nvidia-drivers on mac-mini 4.1 (mid-2010).
I will try to figure it out!

womp

womp

Don’t worry about that for now, Xorg develepment has been put aside as it seems. Red Hat is focussing on Wayland at the moment and not so much on further development on Xorg.

1 Like

You didn’t have to do any EFI magic to get the nvidia card to turn on? I tried to install the drivers and got the dreaded black screen. Even with nomodeset. I believe I even used this post to make the changes in lightdm.conf. Still black screen.

I have made the changes in the EFI boot and it seems like that might work. But I am hesitant to install the drivers because I’ve been using the laptop heavily lately and do not want to spend time fixing it. :upside_down_face:

Hi!
When I installed on mac-mini I followed a “hint” I found. I wrote it down and that was lucky because I could not find it when I was looking for it just now.
Here it comes:

sudo lshw -businfo -class bridge -class display

Bus info Enhet Klass Beskrivning

pci@0000:00:00.0 bridge MCP89 HOST Bridge
pci@0000:00:03.0 bridge MCP89 LPC Bridge
pci@0000:00:0e.0 bridge NVIDIA Corporation
pci@0000:01:00.0 bridge XIO2213A/B/XIO2221 PCI Express to P
pci@0000:00:15.0 bridge NVIDIA Corporation
pci@0000:00:16.0 bridge NVIDIA Corporation
()pci@0000:00:17.0 bridge MCP89 PCI Express Bridge
(
)pci@0000:04:00.0 display MCP89 [GeForce 320M]

sudo nano /etc/grub.d/01_enable_vga.conf

cat << EOF
setpci -s “00:17.0” 3e.b=8
setpci -s “04:00.0” 04.b=7
EOF

~$ sudo chmod 755 /etc/grub.d/01_enable_vga.conf
~$ sudo update-grub

~$ sudo setpci -s “00:17.0” 3e.b
08
~$ sudo setpci -s “04:00.0” 04.b
07

I didnt work the first 2-3 times I installed but then it worked!

Hope this can help!!

womp

Top @womp . Thx for sharing, might help other members in the futuew.

1 Like