Archlabs ISO fails to install on ASUS X570 motherboard

If you want to try a build using pacstrap rather than iso copy (fixed the issue I had with cinnamon install)
then let me know.

Sure, I can try this. How do I do a pacstrap install?

I’m just working on adding the option to use the old method vs pacstrapping as it’s significantly faster

OK, I’ll try it. What do I do different for this install compared to normal?

Nothing, The only change was to the background install portion. Before we copy the iso filesystem to the new mount and then update, that iso will just do pacstrap instead. I’m sure there will be some issues like wrong os name etc but minor. I’ll be patching those up.

So I tried installing the ISO and it didn’t work. Now I can’t get the older ISO to work either - I get an error like this:

Command: 0

Error: Error: Expecting a partition number.

Now what do I do?

-The NVME drive appears to be blank
-I had changed a couple UEFI settings beforehand, although changing them back doesn’t appear to work either.

What point during install do you get this?

At this point I think you should just do a manual install to see what actually happens and get a idea of what’s happening.

I get the error specified above when I’m formatting my NVME drive. I also was getting more “fallocate failed” when adding a swap file and “no error description available” errors when installing the operating system.

how do I do a manual install?

Format and mount your partitions to /mnt and /mnt/boot for root and boot respectively.

For ext4 you can do

mkfs.ext4 -q /dev/ROOT_PARTITION

For vfat (EFI boot)

mkfs.vfat -F32 /dev/BOOT_PARTITION
mount /dev/ROOT /mnt
mkdir /mnt/boot
mount /dev/BOOT /mnt/boot

Update the mirrorlist first to speed up downloads

reflector --score 100 -l 50 -f 10 --sort rate --save /etc/pacman.d/mirrorlist --verbose

Now pacstrap it

pacstrap /mnt base base-devel

Once that finishes you have a baseline arch install to work with and install packages into

arch-chroot /mnt

Now you’re inside the system you can run pacman commands to install what packages you like.

If you make it to this point I would try creating a swap file as that seems to be where it’s always failing for you

fallocate -l 8G /swapfile
chmod 600 /swapfile
mkswap /swapfile
swapon /swapfile

I suspect you’ll get a similar error at this point, if not we’ll continue.

1 Like

Thank you SO MUCH for your help natemaia!

Using your commands above, I was finally able to install my Archlabs Linux using this process:
-disable secure boot and wipe ALL KEYS
-set OS type to “Other OS”
-enable Compatibility Support Module (with boot device control set to Legacy & UEFI)
-disable the IOMMU controller
-enable SVM mode (virtualization)
2.) pre-installation
-Use a Linux Mint LiveCD to pre-format your drive into 3 partitions:
a. 600mb vFAT drive
b. 200-1TB ext4 drive
c. 2-16GB SWAP partition

3.) Actual Install
-Use natemaia’s beta ISO shown above and flash it to a USB stick
-boot into the USB in LEGACY mode using the F8 boot menu
-before running archlabs-installer, run these two commands:

mkfs.vfat -F32 /dev/nvme0n1p1
mkfs.ext4 -q /dev/nvme0n1p2

remember to replace the above labeled partitions with your actual partitions

Now run archlabs-installer
-once you reach the main menu, skip down to option 4.1 “mount partitions” and follow the instructions to reformat your GRUB and ROOT partitions. Do NOT reformat your partitions using option 2 in the main menu.
-continue as normal

Hopefully this should work for anyone else struggling with Arch Linux boot and installation on an Asus X570 motherboard.

1 Like

What a strange outcome, the mkfs commands are what’s run in the installer with the exception that the boot one is defaulted to “No” so we don’t accidentally wipe other OS’ bootloaders.

At any rate I’m glad you got it.

The latest ISO (from GoogleDrive) installs well on my damned new machine in EFI, but does not start:

In legacy mode it keeps crashing due to the “Partition / too full” error. I partitioned automatically.

Just for curiosity, as my brand new MSI alpha 15 is a piece of crap, useless with Linux. The problem is, that it’ll be damned difficult to return it to the seller. :confused:

It would be better for you to start another topic instead of continuing, as this forum is already “solved” and you’re less likely to get help here than in a new forum.

I don’t expect any help. Just pointed out that the legacy mode might have not yet been fixed in the latest iso.

did you try this nwg?

You described partitioning for EFI installation, which goes well anyway, but the system does not start. I wanted to try legacy mode. I was able to do it on vanilla Arch, but the system won’t boot afterwards.

Out of desperacy I installed Ubuntu, and it works with no problem, but does not detect the hdmi display. :confused:

Have you tried nomodeset kernel flag?

Yes. It just stops in another place: after “Reached target Graphical Interface”.