ArchLabs Linux

Archlabs-installer installation error

After my catastrophic hard drive failure I had to take some time off to recover from the event but I’m back! I tried to do an install but found this problem. Can someone point out what could be the problem here?

Selected autopartitioning, linux-hardened, grub as boot loader, no encryption, (fluxbox,openbox,i3-gaps) as WM, range of misc apps.

Sorry for the issue.

Install with the stock kernel instead and switch to hardened after. Seems like it failed to install the hardened kernel so the mkinitcpio preset is missing.

1 Like

Thanks. I got pass that error but now getting this error during install.

Could be bad media! Download the image again and try!

womp

stock kernel is vanilla right?

yea you got it

Hello,
I receive the exact same error. It doesn’t matter what kernel I choose. I continue to receive this error. I have also re-imaged my usb device, redownloaded the iso and reformatted the drive I am installing to.

The strange part is that I was able to use it to install on my desktop yesterday, but now I keep getting this error when trying to install on my laptop.

I’ve been helping leo in a PM so I didn’t have to share testing isos in a live thread but since others are having the same problem I’ll move back here.


@cg615 are you doing the same install or minor changes?

Is the error message something to do with lightdm or graphical.target?

Hey there Natemaia,

So to answer your first question, not the same install. My initial install attempt was as follows:

  • Custom partition
  • linux-lts
  • grub
  • no encryption
  • i3-gaps and gnome
  • Also a range of different additional applications

After launching the install I would receive the error leo00 received "…exited abnormally: 1 /usr/bin/mkinitcpio line 261:…linux-lts.preset: No such file or directory.
I then received the same error after doing as you instructed above installing the linux-vanilla.
However, I resolved the issue by not installing additional packages except for emacs, firefox, and rxvt-unicode.

The additional apps that I did install where the following:
Firefox
emacs
pacmanfm
rxvt-unicode
vlc
thunderbird
libreoffice-fresh
gimp
kdenlive
simplescreenrecorder
qpdfview
all fonts
deluge
steam
docky

I eliminated Firefox, emacs, and rxvt-unicode as possible sources of the issue, but was not able to continue troubleshooting. The only way I ended up getting Linux up and running was to not install any other packages. I just installed them after I was up an running.

I should clarify that the long list of apps were installed during the failed attempts. Bypassing the installation of these apps led to the successful install of Arch Labs on the lts kernel.

Docky’s no longer in the official repos leading to a large portion of the package install to fail. The user selected packages failing shouldn’t affect crucial things like the kernel, that was my mistake.

Interesting! I never would have thought docky of all things would be the culprit! Thanks for the help.